need help on power loss - Ford Powerstroke Diesel Forum
Introductions This is the place that you introduce yourself

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-18-2007, 05:30 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2007
Location: Pa
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy need help on power loss

Any ideas, 01 dually running edge attitude 4 dp 5 exhaust k&n intake. Had
number 8 injector go out two weeks ago. I've recently had both valve cover
harness changed out. Changed out fuel filter about a month ago. Ran great
after injector then it seemed to loose power again. It did gel up on me last
tues. put additive in drained fuel filter and still had the power problem. I took
it to the dealer being I have no access to a scan tool, they can't find anything wrong. Did cylinder test and injector test check turbo no sure what else they kept the paper work and left the work order open. I did disconnect
the ebp sensor but no change. I'm not seeing any smoke but do have more
than usual soot on the truck itself but I was kind of contributing that to the new exhaust being a little shorter than stock. No tip yet..The power loss seems like a miss and does it more under load than at idle. Not as bad on straight aways but hills it sucks. You can deffinitly here it in the motor that
its not running right.Please help...Sorry so long...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-18-2007, 05:36 PM
The Fat Mod
 
Join Date: Aug 2006
Location: Hickory, NC
Posts: 12,509
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
First off...



To POWERSTROKE.ORG




Did you change the fuel filter after the gel incident? That maybe it, got cloged and is starving the motor for fuel?
Reply With Quote Quick reply to this message
  #3  
Old 02-18-2007, 05:45 PM
Powerstroke.org Rookie
 

Join Date: Feb 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hey i had the same problem on my 95 f250. come to find out the catyletic converter was bad clogged up and not releasing exhaust.
fixed it and know it runs like it was new.
Reply With Quote Quick reply to this message
  #4  
Old 02-18-2007, 05:48 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2007
Location: Pa
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No cat on exhaust change, I didn't change out the filter I thought about it
but it was going down hill before that. I guess it wouldn't hurt..
Reply With Quote Quick reply to this message
  #5  
Old 02-18-2007, 05:51 PM
im fat and ugly


 
Join Date: Aug 2006
Location: Shreveport, LA
Posts: 15,688
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
hope we get ya fixed up
Reply With Quote Quick reply to this message
  #6  
Old 02-18-2007, 05:54 PM
The Fat Mod
 
Join Date: Aug 2006
Location: Hickory, NC
Posts: 12,509
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Yeah, anytime you gel, you need to change the fuel filter. It maybe something else, but that def wont hurt.
Reply With Quote Quick reply to this message
  #7  
Old 02-18-2007, 05:59 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2007
Location: Pa
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'll do that..thanks for the help and welcome. Could there still be a injector
on the way out thats not showing up on scan?
Reply With Quote Quick reply to this message
  #8  
Old 02-18-2007, 06:01 PM
The Fat Mod
 
Join Date: Aug 2006
Location: Hickory, NC
Posts: 12,509
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Did they do a buzz test or anything like that? Or did they just scan it with a scan tool?
Reply With Quote Quick reply to this message
  #9  
Old 02-18-2007, 06:02 PM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: Silver Lake Or.
Posts: 786
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
to the site
Reply With Quote Quick reply to this message
  #10  
Old 02-18-2007, 06:13 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2007
Location: Pa
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
They said they did comp. checks on cylinders and injectors not sure since I don't have paper work. Told they couldn't find anything wrong. The guys suppost to be a master mech. on diesels. LOL If it dosen't show up on scan
they don't know??What gives there..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:42 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors