7.3L Diesel not starting properly... - Ford Powerstroke Diesel Forum
Ideas and Suggestions If ideas are never brought up, they never have a chance of happening!!!

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 02-25-2013, 06:39 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Feb 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
7.3L Diesel not starting properly...

My 1999 Ford F-350 7.3L diesel is not starting properly. It starts just fine when it is plugged in or already warm, other than that I have a really hard time getting it to start. I have asked around and some people think that it could possibly be glo plug relays or glo plugs but I'm not sure. Anyone have any suggestions on what it could be?
vegors34 is offline  
post #2 of 3 Old 02-27-2013, 03:01 AM
Compression Ignition Addict
 
Join Date: Oct 2012
Location: Edwardsville, IL
Posts: 228
Thanks: 8
Thanked 10 Times in 10 Posts
Mentioned: 0 Post(s)
Quoted: 11 Post(s)
Feedback Score: 0 reviews
Check this out. Its in the 99-03 7.3 section.
Troubleshooting GPR & GP's
welove2drive is offline  
post #3 of 3 Old 02-27-2013, 09:56 AM
Powerstroke.org Rookie
 
HONEST FORD OWNER's Avatar
 
Join Date: Feb 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by vegors34 View Post
My 1999 Ford F-350 7.3L diesel is not starting properly. It starts just fine when it is plugged in or already warm, other than that I have a really hard time getting it to start. I have asked around and some people think that it could possibly be glo plug relays or glo plugs but I'm not sure. Anyone have any suggestions on what it could be?

I know my 1991 f-350 7.3L did the same thing and once I changed 4 of the glow plugs that were bad it started like new. Also Mine would not start when it was warm and all I had to do is starting using a fuel addative and it lubricated the injection pump so I didn't have that problem anymore. I hope this helped.

2012 FORD F-350 DRW CC LB FX-4 ULTIMATE LARIAT
HONEST FORD OWNER is offline  
Reply

Tags
glo plugs , not starting , suggestions

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome