Wow I have to say Ive had the absolute worst experience with a company ever - Ford Powerstroke Diesel Forum
HyperTech Hypertech Inc.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-21-2012, 07:20 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 31,151
Thanks: 116
Thanked 104 Times in 95 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
Wow I have to say Ive had the absolute worst experience with a company ever

I literally just got off the phone with Tech support regarding an issue with my brother in laws truck and a max energy tuner.

About two weeks ago his truck was in at ford having the EGR and oil cooler replaced.

Truck came back out and tuner didnt work. Spoke to a guy at tech support last week he did an update.

Tried the update yesterday.

It went as far as reading the ECM then it cut me off telling me the strategy isnt supported.

Called tech a few moments ago. And told him that he said it was impossible and he needed an error code. After telling him there wasnt a code popping up 4 times and requesting to speak to someone else.

He flat out told me there wasnt anyone more knowledgeable and that he'd been there 23 years.


My Brother in laws pissed that hes got basically a 400 dollar doorstop now.

And I have to agree.

Ive never had such a poor experience with customer service in my life
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-21-2012, 07:27 AM
Premium Member
 

Join Date: Oct 2010
Posts: 1,940
Thanks: 0
Thanked 21 Times in 19 Posts
Feedback Score: 0 reviews
Well sounds like that tech guy is having a case of the "Monday's"...

Last edited by a2elvis; 05-21-2012 at 07:28 AM. Reason: Didnt see the Hypertec heading
Reply With Quote Quick reply to this message
  #3  
Old 05-21-2012, 07:58 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 31,151
Thanks: 116
Thanked 104 Times in 95 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
There talked to a different guy. Got the issue looked into.

I'll know if it will work in about 3-5 days
Reply With Quote Quick reply to this message
  #4  
Old 05-30-2012, 08:44 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 31,151
Thanks: 116
Thanked 104 Times in 95 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
Going on day 7 with no resolved issues here. Got the run around from their tech guy after I told em that if I was dealing with an SCT tuner this would be a two day turnaround max.
Reply With Quote Quick reply to this message
  #5  
Old 05-30-2012, 08:47 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 31,151
Thanks: 116
Thanked 104 Times in 95 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
I loved hearing how they invented the tuning industry
Reply With Quote Quick reply to this message
  #6  
Old 06-01-2012, 07:21 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 31,151
Thanks: 116
Thanked 104 Times in 95 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
Got an update from the engineering dept yesterday. That makes me much happier.

Much better guy than the tech support staff.

Thanks
Reply With Quote Quick reply to this message
  #7  
Old 06-01-2012, 07:31 AM
Premium Member
 

Join Date: May 2012
Location: Columbus OHIO
Posts: 483
Thanks: 3
Thanked 0 Times in 0 Posts
Feedback Score: 22 reviews
Still sounds like their customer service is rather lacking...Glad they working on it though for ya!
Reply With Quote Quick reply to this message
  #8  
Old 06-26-2012, 08:21 AM
Powerstroke.org Sponsor
 

Join Date: Aug 2007
Posts: 72
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Dave View Post
Got an update from the engineering dept yesterday. That makes me much happier.

Much better guy than the tech support staff.

Thanks
Hi Dave,

I wanted to follow up to see if we got your issue taken care of.

I apologize that we haven't responded to your posts on this forum. We have recently rearranged some of the forum monitoring duties, and somehow this forum got lost in the reshuffle.

Chris
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:20 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors