VT365 in Case backhoe? - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-15-2014, 07:07 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2014
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
VT365 in Case backhoe?

Hi, everyone. A few friends and I were discussing the 6.0 liter and one claims the International version, the VT365, was used in Case backhoes. I can't find any information on Case ever using a 6.0 V8 in a backhoe.

Does anyone have any info? I have an email into Case CE because now I am curious

Thanks,


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
2012 Ram 2500 Laramie Longhorn, black, 6.7L Cummins, auto, shortbed Ram Box.
Sixinarow is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome