Anyone have the new cam sensor fail? - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-24-2008, 05:19 AM
Member
 

Join Date: Dec 2007
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Anyone have the new cam sensor fail?

80 mph with 3500lb trailer and the engine died. Mechanic calls and says code is for cam sensor. Truck fired up and ran every time all day while he had it in the shop. He is replacing the sensor today, also read code for low injector pressure after the cam code.


Anybody else have the cam sensor go out SINCE the recall?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-24-2008, 05:21 AM
Member
 

Join Date: Dec 2007
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
BTW, 2002 F250, 7.3 PSD.
Reply With Quote Quick reply to this message
  #3  
Old 07-24-2008, 05:21 AM
Serving Our Country!
 

Join Date: Jul 2008
Location: Virginia Beach, Va
Posts: 349
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had mine replaced when the recall came out, but I havent had any problems since.
Reply With Quote Quick reply to this message
  #4  
Old 07-24-2008, 05:23 AM
Member
 

Join Date: Dec 2007
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Had mine replaced 3 months ago and I am furious that the newly designed part failed.
Reply With Quote Quick reply to this message
  #5  
Old 07-24-2008, 06:03 AM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Arnold, Mo
Posts: 1,566
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No haven't had a problem yet with the new one, but if I remember correctly they only have a 12,000 mile warranty on them. So it seems they haven't really gotten anything fixed.
Reply With Quote Quick reply to this message
  #6  
Old 07-24-2008, 06:04 AM
Compression Ignition Addict
 

Join Date: Mar 2008
Posts: 642
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to kx592
mine was already malfunctioning when i bought my truck so i spent all of 20$ and put a new one in....
Reply With Quote Quick reply to this message
  #7  
Old 07-24-2008, 07:32 AM
Member
 

Join Date: Dec 2007
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Terrible customer service from Ford

Called Ford customer service and let them know my replacement sensor failed and that I wanted Ford to pay my repair bill at my mechanic's shop.

Said I would have to go to Ford dealer for service and when I said I would never let that dealer touch my truck again they said nothing they could do for me.

I have had numerous problems with this particular dealer and always seem to leave with more problems that fixes.
Reply With Quote Quick reply to this message
  #8  
Old 07-24-2008, 07:37 AM
Compression Ignition Addict
 

Join Date: Mar 2008
Posts: 642
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to kx592
Powerstrokehelp.com Bill there can teach you everything you will need to know how to fix your truck yourself.
Reply With Quote Quick reply to this message
  #9  
Old 07-24-2008, 07:42 AM
Member
 

Join Date: Dec 2007
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had replaced my CPS with an O'Reilly part with a lifetime warranty. I took it in for the recall and told them to leave my old part in the cupholder (spare).

The dealer tossed my old part and low and behold I get stranded. I am just being cool to my mechanic who has taken great care of me by letting him replace the CPS. He spent a good deal of time on my ride and charged me nearly nothing so I am throwing him a bone with this one. Working man deserves to get paid, but I did tell him I knew the cost of the part and how easy it is to replace so I wasn't paying crazy money for the fix.
Reply With Quote Quick reply to this message
  #10  
Old 07-28-2008, 08:03 AM
Powerstroke.org Rookie
 

Join Date: Jan 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
CPS started giving me trouble two days after I got the recall notice.I had it changed and the new one started to give me trouble the next day!Anyone try the "new and improved" International blue sensor?Suppose to send a better signal to the Ford computer.International part # 1807339C92
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:42 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors