need advice - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-03-2008, 06:49 PM Thread Starter Rookie
Join Date: Jun 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
need advice

just got finished changing my egr cooler and i am pretty sure i got the steaming exhaust problem fixed. now i have a miss that i didnt have before i tore it only stands to reason that i missed something when i put it back together.i have looked everything over pretty well and cant find anything unplugged or out of place.there is no check engine light.could i have plugged an injector in wrong and still be able to get the retaining clip in? any advice you guys have will greatly appreciated.
jjt2004 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome