2006 F350 SD 6.0 Rough Idle, Loss of Power - Help - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-21-2008, 02:49 PM
Powerstroke.org Rookie
 

Join Date: Apr 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2006 F350 SD 6.0 Rough Idle, Loss of Power - Help

2006 F350 SD 6.0 38K miles - While towing my 5th Wheel back from Ca. to Las Vegas over Baker grade, I noticed what felt like the truck was missing (feels like plug wire was off, if this was a reg gas eng) and very low power on bottom end, truck would hardly start off the line, even with trailer off the vehicle, pulling up in driveway is questionalbe. No smoke, temps all read fine. While rev eng, it misses at low RPM, but seems ok at high RPM. Problem started about 60 miles into new tank of fuel from truck stop. I've changed out both fuel filters this morning, no change in trucks performance. No eng lights showing. Thanks Mike
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-22-2008, 07:30 AM
Powerstroke.org Rookie
 

Join Date: Aug 2007
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bad load of fuel
Reply With Quote Quick reply to this message
  #3  
Old 04-22-2008, 08:11 AM
Powerstroke.org Rookie
 

Join Date: Apr 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Drained all fuel, replaced filters, same issue - had truck towed to Dealership late yesterday. Thanks for the input.
Reply With Quote Quick reply to this message
  #4  
Old 06-01-2008, 10:05 AM
Powerstroke.org Rookie
 

Join Date: May 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
have same problem

05 psd 29,000 miles just driving 40 mph and went to a miss now rough idle and power loss
Reply With Quote Quick reply to this message
  #5  
Old 06-01-2008, 07:29 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Bolton
Posts: 786
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
fuel pump? Loss of coolant?
Reply With Quote Quick reply to this message
  #6  
Old 06-01-2008, 07:33 PM
My 6OH Hates Me


 

Join Date: Sep 2007
Location: Nexus of the Universe
Posts: 24,735
Thanks: 8
Thanked 17 Times in 16 Posts
Feedback Score: 1 reviews
I had a similar problem with the 2006 I just bought. The guy before me didnt change the fuel filters. 33,000 miles. The dealer had to put in a new fuel pump and new injectors all covered under warranty. Truck runs like new now. Good luck.
Reply With Quote Quick reply to this message
  #7  
Old 06-01-2008, 07:36 PM
Rice Hunter
 

Join Date: Aug 2007
Location: Norfolk,VA...Near the beach
Posts: 4,036
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ANY UPDATES SANDPIRATES??
Reply With Quote Quick reply to this message
  #8  
Old 05-17-2009, 08:57 PM
Powerstroke.org Rookie
 

Join Date: May 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have the same problem

I would really like to know how sandpirates2 fixed this problem. My problem is EXACTLY the same. Towing my fifth wheel, got fuel at a little dump of a gas station, lost power on the way home. Changed fuel filters twice, and they were BAD. I have been through several tanks of fuel added fuel injector cleaner and cetane booster. I have enough power to pull the rv but it is not the same as before. Idles rough, smooths out at higher rpm, definitely does not have the power it did before.

I am a FNG with diesels!
Reply With Quote Quick reply to this message
  #9  
Old 10-12-2011, 09:43 PM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Location: Bay Area, CA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Sandpirates2 View Post
2006 F350 SD 6.0 38K miles - While towing my 5th Wheel back from Ca. to Las Vegas over Baker grade, I noticed what felt like the truck was missing (feels like plug wire was off, if this was a reg gas eng) and very low power on bottom end, truck would hardly start off the line, even with trailer off the vehicle, pulling up in driveway is questionalbe. No smoke, temps all read fine. While rev eng, it misses at low RPM, but seems ok at high RPM. Problem started about 60 miles into new tank of fuel from truck stop. I've changed out both fuel filters this morning, no change in trucks performance. No eng lights showing. Thanks Mike
Did you find out the problem. I am having the exact same symptoms.
Reply With Quote Quick reply to this message
  #10  
Old 10-19-2011, 07:05 PM
Compression Ignition Addict
 

Join Date: Jan 2009
Location: Central PA
Posts: 552
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to BennyLumpkin
Thats what mine did when it dropped an injector.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:31 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors