03' 6.0 diesel blowing white smoke and sputtering - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-10-2008, 10:47 AM
Powerstroke.org Rookie
 

Join Date: Apr 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03' 6.0 diesel blowing white smoke and sputtering

I have an 03' excursion and there is loss of power and the truck sputters when crusin, the RPM's are around 1600-2100. When a good load is on the motor (acceleration or deceleration) it does not sputter but definate power loss in acceleration. Another thing that happens is I will step on the gas from a stop and the motor reves up and will start dumping a ton of white smoke but hardly moves. To me if feels like the turbo is not kicking in and then all of the sudden it will go back into working and take off. It always did this when it was cold but now it could be completely up to temp and will still do it. I had the turbo replaced about 30,000 miles ago and same with EGR. Please help if you can.

Jared
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-10-2008, 11:21 AM
Compression Ignition Addict
 

Join Date: Jan 2006
Location: Houston, Texas
Posts: 1,257
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Not sure I can help much but maybe the VGT on the turbo or a dirty EGR maybe???
Reply With Quote Quick reply to this message
  #3  
Old 04-10-2008, 03:01 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: forest lake, minnesota
Posts: 2,297
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
dirty egr valve ?? try cleaning it out
Reply With Quote Quick reply to this message
  #4  
Old 04-10-2008, 03:04 PM
Compression Ignition Addict
 

Join Date: Jan 2007
Location: lusby,md & duncansville,PA
Posts: 998
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by scotty2280 View Post
dirty egr valve ?? try cleaning it out
yea that be my guess

Matt
Reply With Quote Quick reply to this message
  #5  
Old 04-10-2008, 03:06 PM
Powerstroke.org Fanatic
 

Join Date: Mar 2008
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
COULD BE EBP SENSOR AND ALOT OF OTHER THINGS.
Reply With Quote Quick reply to this message
  #6  
Old 04-10-2008, 03:08 PM
Member
 

Join Date: Apr 2008
Location: corona
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i had the same problem. it was an injector that took a dump
Reply With Quote Quick reply to this message
  #7  
Old 04-10-2008, 03:14 PM
im fat and ugly


 
Join Date: Aug 2006
Location: Shreveport, LA
Posts: 15,688
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
sounds like an egr cooler that crapped out
Reply With Quote Quick reply to this message
  #8  
Old 04-10-2008, 03:14 PM
Powerstroke.org Fanatic
 

Join Date: Mar 2008
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ANY CEL? I CAN RUN CODES.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:03 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors