ford 7.3 doesnt boost over 20? - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-08-2013, 01:48 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ford 7.3 doesnt boost over 20?

I have the ts 6 position tuner in my truck and on the first setting it hits 15-16 psi on the 140 hp setting it hits 20. Which is the extreme race setting. Highest it goes. Two questions. Why is it only 20? And next question is. Is 140 hp accurate with the tuner or do you need more mods to make the 140 hp setting accurately 140hp gain
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-11-2013, 03:58 PM
Compression Ignition Addict
 

Join Date: Aug 2011
Location: Damariscotta Maine
Posts: 620
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
On 140ho , at 3000+ rpm I was seeing about 23psi. I don't think your very far off. Its only 20 because thats all the fuel you have to spin the turbo.

Down the road a few months, I got new injectors (more fuel) same turbo(for a while :p) and setup, seeing 40+.

20# on a stock truck with a chip is pretty reasonable, 15 for stock is also fine.
Reply With Quote Quick reply to this message
  #3  
Old 03-15-2013, 12:56 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does your truck engine temp run on the cold side? Mine goes up maybe 1/8 n stays there...also what would u recommend for injectors and fuel system if I were to throw a 38r on my truck. I have exhaust intake chip turbo timer foil delete ccv mod zoodad mod etc. Need head studs injectors n fuel system and maybe a fuel pump
Reply With Quote Quick reply to this message
  #4  
Old 03-15-2013, 03:03 PM
Compression Ignition Addict
 

Join Date: Oct 2009
Location: hudson, fl
Posts: 2,820
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by bmendes9 View Post
Does your truck engine temp run on the cold side? Mine goes up maybe 1/8 n stays there...also what would u recommend for injectors and fuel system if I were to throw a 38r on my truck. I have exhaust intake chip turbo timer foil delete ccv mod zoodad mod etc. Need head studs injectors n fuel system and maybe a fuel pump
if your engine is always running cold, I'd say its a safe bet to say that the t-stat is stuck, time for a new one.
Reply With Quote Quick reply to this message
  #5  
Old 03-15-2013, 04:05 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Someone once told me 18 wheelers have that problem but all they do is block have the radiator wirh something and it fixes the issue. I'd say if that don't fix it maybe then change the t stat
Reply With Quote Quick reply to this message
  #6  
Old 03-15-2013, 04:07 PM
Compression Ignition Addict
 

Join Date: Oct 2009
Location: hudson, fl
Posts: 2,820
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by bmendes9 View Post
Someone once told me 18 wheelers have that problem but all they do is block have the radiator wirh something and it fixes the issue. I'd say if that don't fix it maybe then change the t stat
Where are you located and whats the temp outside. Some people run a winter grill, but I live in fl, never ran one. If its something that the truck has always done, in warm weather/cold whatever, then its most likely the stuck tstat.
Reply With Quote Quick reply to this message
  #7  
Old 03-15-2013, 04:18 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I live in ct. Just bought the truck and haven't had any chance to see how it runs in warm weather.
Reply With Quote Quick reply to this message
  #8  
Old 03-15-2013, 04:23 PM
Member
 

Join Date: Feb 2012
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Re: ford 7.3 doesnt boost over 20?

Anytime of year I was seeing 28-30 on my php 120 race tune. It was 20deg to 95deg is sc. 99 zf6 with no leaks and 3000psi with the hpop on my scangauge.

Sent from my Milestone X2 using AutoGuide.Com Free App
Reply With Quote Quick reply to this message
  #9  
Old 03-15-2013, 04:27 PM
Powerstroke.org Rookie
 

Join Date: Mar 2013
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I noticed you have a 38r on your truck how hard was it to do the swap and what did you have to change on it..did you change the pedestal on.it. mine is leaking and I wanna.change everything in that area
Reply With Quote Quick reply to this message
  #10  
Old 03-15-2013, 04:28 PM
Compression Ignition Addict
 

Join Date: Oct 2009
Location: hudson, fl
Posts: 2,820
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by td04ptgt View Post
Anytime of year I was seeing 28-30 on my php 120 race tune. It was 20deg to 95deg is sc. 99 zf6 with no leaks and 3000psi with the hpop on my scangauge.

Sent from my Milestone X2 using AutoGuide.Com Free App
The temp was more related to his engine registering cold.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:34 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors