Engine damage? - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 01-27-2013, 03:41 PM Thread Starter
Compression Ignition Addict
 
Jack Lester's Avatar
 
Join Date: Jan 2013
Posts: 297
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Engine damage?

I have a 06 6.0 I changed the coolant I used peak anti-silicate formula. I filled it up and drove it bout 8 miles and checked it I had to add a little over half a gallon to bring it up to operating level my gauge never spiked or moved higher ths it normally runs. Did I do damage? What coolant should I run?
Jack Lester is offline  
post #2 of 2 Old 01-27-2013, 05:11 PM
Compression Ignition Addict
 
Join Date: Jan 2010
Posts: 454
Thanks: 0
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Probably just didn't purge all the air out and needed topping off. I doubt you did any damage. Try the 6.0 section for specific details/questions.

Chris
1984 F-350 XLT 4x4 4spd. 6.9 (project)
1996 F-250 XLT 4x4 5spd. 7.3
2001 Excursion XLT 4x4 Auto 7.3
AMSOILdealer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome