help me please... wait to start light wont come on - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 09-29-2011, 08:12 AM Thread Starter Rookie
Join Date: Sep 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy help me please... wait to start light wont come on

Hi I have a 83 f350 6.9 international diesel.

I drove my truck 4 days ago, I was trying to install a radio and by accident I unplug one of the wires that comes from the glow plug relay to a switch inside the cabin.I tried starting the truck and nothing happen so I notice that I unplug one the wires that connect to the switch so I bypassed the switch and left the wires connected over night and drained both batteries. Well I pluged the wires back to the switch charged both batteries and now the wait to start light won't come. I touch the glow plug relay and is getting hot when i turn the switch. But my truck don't start.
druk is offline  
Sponsored Links

6.9, 83 truck, f350, ford, wait to start

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome