Need HELP with my ISSPRO EV2 gauges! - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-24-2011, 05:41 PM
That's what she said!
 

Join Date: May 2010
Location: Bridgewater, NJ
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation Need HELP with my ISSPRO EV2 gauges!

Ok so I Just bought a 3-gauge ISSPRO kit from Thoroughbred Diesel, the EV2's, and I installed them today. Now I installed a Trans Oil Temp, an EGT, and a Boost. The trans temp is acting up. It has the stepper motor in it and everytime it performs the stepping action it lands on a different temp, most recent being 120-130 and back to 120. This is with the truck off and the key in the on position. I cycle the key and it goes to 120 then I turn it off and back to the on position and now 130. I cycle the key again and now its back to 120. I am confused. Another instance was when I turn the truck to the on position and engine off and the stepper motor steps up and never comes back down. I turn off the truck and back on and it just keeps increasing untill it reaches the pin past 280. I dont understand what could be wrong but I have tried their troubleshooting on their website and no luck. Hope someone can help me.

On a seperate note the EGT gauge is not going bellow 100 and i am just wondering if that is normal? it performs fine to the best of my knowlege when truck is running but when i turn off my truck it stays at the last read value. I find that odd. Any help here would be great.

As for the Boost Gauge I will finish the underhood portion tomorrow since I ran out of daylight today.

I will try contacting ISSPRO in the am as well as Thoroughbred Diesel since that is where I purchased the gauges from... Im leaving for Nashville, TN June 6th and was hoping to have all my bugs and kinks taken care of before then so I can Install the DP-Tuner I have also.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-25-2011, 06:07 PM
That's what she said!
 

Join Date: May 2010
Location: Bridgewater, NJ
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
**UPDATE**
Now I installed my boost gauge and it does not read less than 4psi even at idle... I thought there would be vacuum at that point since im not even touching the throttle and adding any boost. Has anyone had this kind of trouble before with their ISSPRO gauges.

I really need some input.

As for my Trans Temp, ISSPRO is sending me a new gauge. They said that the needle on the gauge has friction due to the fact that they forgot to insert some type of bushing or washer thing inbetween the face and the needle. So that is resolved.

As for the EGT gauge, ISSPRO informed me that that is working properly so Im glad one was right and the trans is being resolved.

but Please any input on the Boost gauge would be helpful...

guess a for the night
Reply With Quote Quick reply to this message
  #3  
Old 05-26-2011, 12:17 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2007
Location: Happy Valley, Oregon
Posts: 141
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just an update - I've been in contact with landyacht27, it looks like the boost gauge also had the issue with the sticking pointer, probably built by the same person on the same day they botched the trans temp gauge! I have notified the production line to make sure everyone is trained correctly in that area. We have replacements on their way to him.

Regards,
Michael Pliska
Reply With Quote Quick reply to this message
  #4  
Old 05-26-2011, 12:38 PM
That's what she said!
 

Join Date: May 2010
Location: Bridgewater, NJ
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Michael you have been a great help!!! I would recommend anyone and everyone to buy gauges from you guys. Customer service is beyond fantastic. I will deff be doing business again.

Thanks Michael!!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:35 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors