6.0 surging problems - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-28-2007, 11:06 PM
Powerstroke.org Rookie
 

Join Date: May 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
6.0 surging problems

i have an 04' 6.0 powerstroke with an edge platinum w/attitude monitor. i normally run it on level 2 but for the past 3-4 weeks ive had a couple of occurences where the truck would start surging like i was flooring the gas and letting right back off, this was happening under normal driving conditions 45-55 mph and once while idiling in driveway forward and reverse not even touching gas pedal. thinking it might be due to programmer i changed to level 0 stock but still experiencing same problem.also truck seems sluggish sometimes.any suggestions?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-29-2007, 03:54 AM
Powerstroke.org Fanatic
 

Join Date: May 2007
Posts: 97
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check the connection of the pipe joining your air filter to your turbo, there's a sensor in there and i've seen a few times when my pipe has come off that the truck will do what you describe (in mine, mostly does it at idle, not so much while driving)
Reply With Quote Quick reply to this message
  #3  
Old 07-29-2007, 04:03 AM
Emergency Services
 

Join Date: Oct 2006
Location: tampa, florida
Posts: 1,071
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
try cleaning the egr to see if that helps
Reply With Quote Quick reply to this message
  #4  
Old 07-29-2007, 06:39 AM
If it aint a CAT itsa DOG

 

Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,552
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
my brother has the exact same truck with the same problems, truck just surges forward without touching the pedal. Sometimes at a stoplight or sometimes going down the road. Other guys on here told me to have him check his ICP sensor. My brother replaced it again and i will find out if it helped tomorrow when i talk to him. Let us know what you find out. Good luck!
Reply With Quote Quick reply to this message
  #5  
Old 07-29-2007, 06:54 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,240
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
i agree with cleaning the egr and also checking the icp sensor, if the connection bad at the icp sensor, can cause similiar concern , your best bet though is to have the codes pulled and if the problem is that bad ,there should be a code stored in memory, at least that will help you pinpoint the problem faster
Reply With Quote Quick reply to this message
  #6  
Old 07-29-2007, 08:01 AM
Compression Ignition Addict
 

Join Date: May 2007
Location: Tulsa, OK
Posts: 4,230
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i would try uninstalling the programmer, then drive it w/o the programmer for a day or so to test....
Reply With Quote Quick reply to this message
  #7  
Old 08-01-2007, 08:37 PM
Powerstroke.org Rookie
 

Join Date: May 2007
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks for the info guys. I tried cleaning the egr valve and it was very dirty, but today same problem again. I checked codes with my edge juice programmer and here is what i got

P0649 cruise control lampcontrol circuit.???????????

P1378 FICM supply voltage circuit low.?????????????

not sure what these mean but maybe this will help. Also my truck is a 2004 f250 cc king ranch with a 6" lift and 325/60/20's equal to 35's. my question is with the juice platinum on this truck in level 5 should i be able to smoke these tires from a stop without powerbreaking, because i see vids of severl trucks like this doing it, but im not sure of their mods either. I als0 have a k&n cold air intake and 4" exhaust. Thanks guys
Reply With Quote Quick reply to this message
  #8  
Old 08-02-2007, 02:58 AM
ADMIN AND TECH


 

Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,240
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jdmm61480 View Post
thanks for the info guys. I tried cleaning the egr valve and it was very dirty, but today same problem again. I checked codes with my edge juice programmer and here is what i got

P0649 cruise control lampcontrol circuit.???????????

P1378 FICM supply voltage circuit low.?????????????

not sure what these mean but maybe this will help. Also my truck is a 2004 f250 cc king ranch with a 6" lift and 325/60/20's equal to 35's. my question is with the juice platinum on this truck in level 5 should i be able to smoke these tires from a stop without powerbreaking, because i see vids of severl trucks like this doing it, but im not sure of their mods either. I als0 have a k&n cold air intake and 4" exhaust. Thanks guys
some of the 04 models were bad for chaffed wiring , the 1378 code is a ficm voltage loss code just like the def. says , may want to look over the harness , mostly down the left side of the harness and all around the ficm for wires rubbing valve cover bolts and intake bolts , it cold even be a loose conection going into ficm, have replaced alot of ficm harness for different codes like yours, may need to be taken in to get further diag
Reply With Quote Quick reply to this message
  #9  
Old 08-02-2007, 03:17 AM
Compression Ignition Addict
 

Join Date: Feb 2007
Location: Elizabeth City
Posts: 1,111
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine will surge after i have been toiwing like the converter is trying to lock in. it will idle normally and then it sounds like a small load is thrown on to it. would that be a sensor issue or something worse? truck drives fine, but it sounds like something is wrong.
Reply With Quote Quick reply to this message
  #10  
Old 08-02-2007, 12:56 PM
If it aint a CAT itsa DOG

 

Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,552
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Well my brother got his truck back from the stealer and they replaced the ICP sensor and one other sensor that i can't think of and he took his truck the the oshkosh air show and said it ran like new again. So thanks for all the help guys!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:54 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors