PSD problems.. HELP.. - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-30-2009, 05:48 PM Thread Starter
arcticcat01's Avatar
Join Date: Sep 2009
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
PSD problems.. HELP..

first of all i didnt know where to put this thread so here it goes. on my 1999 7.3 i have a problem with it "roaring" kind of like when you have mud tires going down the highwayexcept this is more high pitch. it sounds to me like the bearings in the left front wheel, and got done wasteing $220 dollars on the left hub assembly and figured that wasnt the problem. any one else ever experience some thing like this, one thing for sure is your ear start popping after about 1 hr being in the truck. oh and you can only hear this noise at about 25 mph to 60 mph.??what can it be???

2004 F-250 arp's, egr delete, sinister coolant filter, 4" turbo back exhaust

2008 F-350 Dually DPF delete, H&S mini max
arcticcat01 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome