6.0 woes - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-12-2006, 02:39 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
6.0 woes

New to this site after searching madly for problems with the 6.0 online. Figured by the time the '06 came out they might have most of the problems worked out.....Well, I got an '06....great truck...til it broke. Same problem, different year....starting problems.(Not to mention a few new issues regarding the speedometer) Dealers got the truck, dealer's got no answers, let alone any idea of when I get my truck back. I'm sure someone out there can tell me what are my chances ( in the event Ford fixes it right ) of not having a continual problem?? There are no mods on the truck(yet) so ford takes the blame,yet again, for this blunder.
ow32382 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-12-2006, 02:40 PM
Banned
 
Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 5 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
what issues are you having??
mschn99 is offline  
post #3 of 4 Old 03-12-2006, 02:49 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Won't start after being run, and after being cold(common) , They said it works fine, then said it was the fuel pump, so they installed a new one...come to find out they never installed it, but I've got the cab off and the engine is torn down for an internal leak...O-ring?
The speedometer has a mind of its own...one day it's fine, the next it zeros off at 50...get some speed and it's buried on 100. oh, and the control head for the ac is fried...
ow32382 is offline  
post #4 of 4 Old 03-12-2006, 03:02 PM
Banned
 
Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 5 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by ow32382
Won't start after being run, and after being cold(common) , They said it works fine, then said it was the fuel pump, so they installed a new one...come to find out they never installed it, but I've got the cab off and the engine is torn down for an internal leak...O-ring?
The speedometer has a mind of its own...one day it's fine, the next it zeros off at 50...get some speed and it's buried on 100. oh, and the control head for the ac is fried...
the no start after a hot soak is the high presure oil pump quick connect fitting at the outlet having a blown white teflon o ring........check the runout in the rear end tone ring.....ive seen a few problems with those causing wiered ABS and speedo problems....and i have not seen the controll head issues....that is a new one for me........Marc
mschn99 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome