ts performace chip - Ford Powerstroke Diesel Forum
General Diesel Discussion Discuss everything else pertaining to Diesel Pickups.

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 09-03-2009, 06:49 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Mar 2009
Posts: 121
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to kyleh20
ts performace chip

hey i have had my chip for about 3 months now and every time i let off the gas at certian points it will bog down and couph it only stalled twice but why would this be? air/ fuel ratio is off?? do i need to get it retuned?

2002 F-250 7.3l 190K
str8 piped exhaust
T4 mount s366 turbo
6637 W/ zoodad
TW custom tunes
18" rockstars with nitto terra grapplers
Pioneer avic-f700bt
Piller mount gauges autometer pyro/boost/tranny
F650 dash w/ fuel pressure and air pressure
Fisher 7.6 HD plow
BTS Transmission
And lights everywhere
kyleh20 is offline  
post #2 of 6 Old 09-03-2009, 07:14 AM
Compression Ignition Addict
 
szyd's Avatar
 
Join Date: Aug 2008
Posts: 3,540
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Is it a TS chip with TS tunes or a TS chip with custom tunes?
Did You clean the board good before installing?
Did you give the PCM code when ordering?
Are you seeing a CEL when the truck is acting up?

Dale

99.5 F 350 Totaled
2000 F350 Lariate
CC
SB
4x4
4" turbo back
cold air. Zoodad
Banks big head
Wicked wheel
4" BDS lift. With Bilstein's
all brought together by TW
szyd is offline  
post #3 of 6 Old 09-03-2009, 12:15 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Mar 2009
Posts: 121
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to kyleh20
I believe it is a custom tuned chip not a tuner and it is not reading any codes when it happens and I did not give ecm code when ordering it was never asked for what would that have done and I also thought that it could be not cleaned properly so I took it all apart and recleaned and made sure it is clean

2002 F-250 7.3l 190K
str8 piped exhaust
T4 mount s366 turbo
6637 W/ zoodad
TW custom tunes
18" rockstars with nitto terra grapplers
Pioneer avic-f700bt
Piller mount gauges autometer pyro/boost/tranny
F650 dash w/ fuel pressure and air pressure
Fisher 7.6 HD plow
BTS Transmission
And lights everywhere
kyleh20 is offline  
post #4 of 6 Old 09-03-2009, 12:32 PM
Compression Ignition Addict
 
Powerstroke W/smoke's Avatar
 
Join Date: Aug 2007
Location: Denver, CO
Posts: 1,034
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
You want to make sure that both circuit boards (the chip and the PCM) are extremely clean on both sides.

Sold!2001 F-350Lariat Lifted 7.3L CC, 5" Straight Pipe, DIY Intake, Foil-Delete, 6 pos chip, CCV Bypass, 37" Toyo MT, Gauges, Blacked out, 07 Harley Front-End.

SOLD!2006 F-250Amarillo 6.0L CC, 4" Straight Pipe, SCT-II

STOLEN ,2001 F-350Lariat 7.3L CC, 6pos chip, 4" Banks Straight-Pipe, Banks Comp Wheel, Custom Lighting, Foil-Delete, Intake.
Powerstroke W/smoke is offline  
post #5 of 6 Old 09-03-2009, 05:01 PM
Compression Ignition Addict
 
szyd's Avatar
 
Join Date: Aug 2008
Posts: 3,540
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by kyleh20 View Post
I believe it is a custom tuned chip not a tuner and it is not reading any codes when it happens and I did not give ecm code when ordering it was never asked for what would that have done and I also thought that it could be not cleaned properly so I took it all apart and recleaned and made sure it is clean
Whos tunes?
Does the truck act up with the chip not pluged in?
A chip will make pre exsisting problems very apparent.

Dale

99.5 F 350 Totaled
2000 F350 Lariate
CC
SB
4x4
4" turbo back
cold air. Zoodad
Banks big head
Wicked wheel
4" BDS lift. With Bilstein's
all brought together by TW
szyd is offline  
post #6 of 6 Old 09-04-2009, 05:17 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Mar 2009
Posts: 121
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to kyleh20
it as bought from raul at stealth automotive so who ever he uses i believe it is tw but no it does not do it when the chip is plugged in which is why i believe it is related to the chip no properly tuned to my truck

2002 F-250 7.3l 190K
str8 piped exhaust
T4 mount s366 turbo
6637 W/ zoodad
TW custom tunes
18" rockstars with nitto terra grapplers
Pioneer avic-f700bt
Piller mount gauges autometer pyro/boost/tranny
F650 dash w/ fuel pressure and air pressure
Fisher 7.6 HD plow
BTS Transmission
And lights everywhere
kyleh20 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome