AC not cooling - Ford Powerstroke Diesel Forum
General 6.7 Discussion General 6.7 Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-28-2014, 05:16 AM
Powerstroke.org Fanatic
 

Join Date: Mar 2013
Location: Houston
Posts: 146
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
AC not cooling

has anyone experienced issues with a/c not cooling. at the same time, it sounds like the blower is clogged... only cools at 60. normally stays at 40. all started saturday when i hooked up a goose neck w/ tractor. not sure if related but i had to use 4wd hi and low but then it would blow in defrost warm and would not come back to the main vents... until i cycled the key, it would blow in the main vents... do these trucks have a/c cabin filters? what about the seats. are there filters in the seats?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-28-2014, 08:24 AM
Member
 

Join Date: Dec 2012
Posts: 54
Thanks: 17
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Sounds like some vacuum issues with the vents.
Reply With Quote Quick reply to this message
  #3  
Old 07-28-2014, 10:47 AM
Powerstroke.org Fanatic
 

Join Date: Mar 2013
Location: Houston
Posts: 146
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
not so much, today wont cool at all. smell freon in vents after it sits. must have a leaking evaporator
Reply With Quote Quick reply to this message
  #4  
Old 07-28-2014, 07:11 PM
Drivin the 6.mOney pit
 

Join Date: Jan 2010
Location: In the sticks
Posts: 1,615
Thanks: 2
Thanked 10 Times in 10 Posts
Feedback Score: 6 reviews
I was gonna say the same as above. My 06 would do that whenever I put it in 4x4. I'm pretty sure it was a vacuum leak but it didn't matter because the POS blew up. Now with the Cummins I dont have to worry about it anyways because the a/c doesn't work period. Lol.

On a serious note, I'd let the dealership fix it under warranty.
Reply With Quote Quick reply to this message
  #5  
Old 08-03-2014, 05:44 AM
Powerstroke.org Fanatic
 

Join Date: Mar 2013
Location: Houston
Posts: 146
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
ended up being the evaporator core. glad i have extended warranty. hope i quit having issues with this truck. radiator, rear view camera, rear view mirror, left outer mirror, idler pulley, drive belt tensioner, oil pan, 110 outlet plug. right at 50,000 miles. bout it used with 27,xxx
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:41 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors