A/c trouble - Ford Powerstroke Diesel Forum
General 6.7 Discussion General 6.7 Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-01-2014, 08:17 AM
Powerstroke.org Rookie
 

Join Date: Jul 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
A/c trouble

Anyone having a/c trouble? When my AC is running the blower fan is making a high pitch noise. The higher you turn up the AC the louder it gets. Any advice before I go to the dealer?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-01-2014, 09:26 AM
Member
 

Join Date: Aug 2008
Posts: 65
Thanks: 1
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
Mine does that when one of the vents is closed and the speed is on high.
Reply With Quote Quick reply to this message
  #3  
Old 07-01-2014, 10:53 AM
Powerstroke.org Rookie
 

Join Date: Jul 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine is doing it with all the vents open. Irritating!
Reply With Quote Quick reply to this message
  #4  
Old 07-01-2014, 01:55 PM
Compression Ignition Addict
 

Join Date: Dec 2011
Location: Denton,TX
Posts: 192
Thanks: 62
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
Anything get sucked I to the in cab intake area?

13' CCSB FX4 6.7, 17"MB wheels, Cooper oversized all terrains, Amsoil 15w40 Diesel/Marine oil with Ea Oil Filter.
Reply With Quote Quick reply to this message
  #5  
Old 07-01-2014, 08:43 PM
Premium Member

 

Join Date: Mar 2014
Posts: 705
Thanks: 22
Thanked 41 Times in 35 Posts
Feedback Score: 0 reviews
Does it sound like a whizzing sound? Kind of like you are putting a playing card into a fan.
Reply With Quote Quick reply to this message
  #6  
Old 07-20-2014, 05:48 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Posts: 380
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
my 11 does this some times but with mine i turn it up all the way and u can hear the fan on but hardly any air comes out of the vents, when its like this u can hear the fan blowing in the blowerbox but something isnt letting it come out of the vents. but i can kill it for 10-15 minutes and it works like its supposed to like it resets itself
Reply With Quote Quick reply to this message
  #7  
Old 07-21-2014, 03:19 AM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i to have an issue , loud blower a wine sometimes and what sounds to be a hiss like its leaking but it still cools the cabin
Reply With Quote Quick reply to this message
  #8  
Old 07-21-2014, 03:34 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Posts: 380
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by BEAR1776 View Post
i to have an issue , loud blower a wine sometimes and what sounds to be a hiss like its leaking but it still cools the cabin
yeah my blower box is loud when it happens, so i know the fan is working correctly just something isn't staying open correctly. mine usually happens when i go down bumpy roads for a long period of time.
Reply With Quote Quick reply to this message
  #9  
Old 07-22-2014, 02:37 AM
Powerstroke.org Rookie
 

Join Date: Jan 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
funny thing yesterday it stopped making noise
Reply With Quote Quick reply to this message
  #10  
Old 07-22-2014, 03:42 AM
Premium Member

 

Join Date: Mar 2014
Posts: 705
Thanks: 22
Thanked 41 Times in 35 Posts
Feedback Score: 0 reviews
I had an issue like that with a 2008 F350 I bought used. The guy who had it before me smoked, and a cigarette wrapper got sucked into the squirrel cage fan in the blower unit. It still worked but made a lot of noise. It drove me NUTS!
I finally figured out how to open up the blower assembly (it was actually easy) and got that little jewel out of there.
Does anyone know if the new trucks are equipped with a cabin air filter? the 08 didn't have one.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:58 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors