Whining fuel pump when KEY ON - Ford Powerstroke Diesel Forum
General 6.7 Discussion General 6.7 Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-30-2013, 11:19 AM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: Cypress TX
Posts: 984
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 1 reviews
Whining fuel pump when KEY ON

So I ran the truck out of fuel a few thousand miles ago and noticed that when I did that the fuel pump in the engine compartment was whining real bad. I filled it up and after a few minutes the whining went away.

Now every time I turn the key to the on position without cranking the pump whines for a 20 - 30 seconds until it fully primes itself.

Shouldnt the fuel system be staying primed? Anyone else notice this?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-30-2013, 04:16 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: Cypress TX
Posts: 984
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 1 reviews
Anyone? .........
Reply With Quote Quick reply to this message
  #3  
Old 04-30-2013, 05:12 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,103
Thanks: 56
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
When was last time you changed fuel filter?

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #4  
Old 04-30-2013, 06:14 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: Cypress TX
Posts: 984
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 1 reviews
7000 of so miles ago. I just changed it right now, we will see if it helps.
Reply With Quote Quick reply to this message
  #5  
Old 04-30-2013, 06:20 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,103
Thanks: 56
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
I think this might solve your problem. I noticed mine was starting to whine a little bit in January right before I changed my fuel filter.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #6  
Old 04-30-2013, 06:27 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2013
Posts: 130
Thanks: 10
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Mine whines now and my truck only has 1,100 miles on it.
Reply With Quote Quick reply to this message
  #7  
Old 05-11-2013, 06:49 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: Cypress TX
Posts: 984
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 1 reviews
Ya my truck is still doing it even after filter change. I guess I just never noticed it. I have no problems with starting and the truck runs great. I also use powerservice regularly.

Oh well. I wont worrry about it for now.
Reply With Quote Quick reply to this message
  #8  
Old 05-11-2013, 06:57 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Location: Clearwater, FL
Posts: 150
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The only time I hear my pump whine is when is extremely low on fuel. And it will whine until I top off. It then goes away.
Reply With Quote Quick reply to this message
  #9  
Old 05-11-2013, 06:58 PM
Compression Ignition Addict
 

Join Date: Oct 2008
Location: Cypress TX
Posts: 984
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 1 reviews
Mine does not whine once running, only when you turn the key to the ON position to let glo plug light for a few seconds. If I leave the key there I can hear it whine for a long time or until I fire up.
Reply With Quote Quick reply to this message
  #10  
Old 05-13-2013, 12:35 PM
Compression Ignition Addict
 

Join Date: May 2010
Posts: 192
Thanks: 5
Thanked 3 Times in 3 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by wreedPS View Post
Mine does not whine once running, only when you turn the key to the ON position to let glo plug light for a few seconds. If I leave the key there I can hear it whine for a long time or until I fire up.
Same here.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:37 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors