Whining fuel pump when KEY ON - Ford Powerstroke Diesel Forum
General 6.7 Discussion General 6.7 Discussion

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 04-30-2013, 10:19 AM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2008
Location: Cypress TX
Posts: 1,107
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 1 reviews
Whining fuel pump when KEY ON

So I ran the truck out of fuel a few thousand miles ago and noticed that when I did that the fuel pump in the engine compartment was whining real bad. I filled it up and after a few minutes the whining went away.

Now every time I turn the key to the on position without cranking the pump whines for a 20 - 30 seconds until it fully primes itself.

Shouldnt the fuel system be staying primed? Anyone else notice this?

2012 F-250 6.7L 4x4 Lariat CCSB, Titan 51gal, BDS 4" kit with Fox Shox, Toyo AT II 35/12.50R20, Ranch Hands front and rear

2007 F-150 King Ranch 4x4 2" Autospring, Bilstein 5100s on all four corners. Nitto A/T 285s.

2005 Chevy Tahoe 5.3l 2WD
wreedPS is offline  
post #2 of 11 Old 04-30-2013, 03:16 PM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2008
Location: Cypress TX
Posts: 1,107
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 1 reviews
Anyone? .........

2012 F-250 6.7L 4x4 Lariat CCSB, Titan 51gal, BDS 4" kit with Fox Shox, Toyo AT II 35/12.50R20, Ranch Hands front and rear

2007 F-150 King Ranch 4x4 2" Autospring, Bilstein 5100s on all four corners. Nitto A/T 285s.

2005 Chevy Tahoe 5.3l 2WD
wreedPS is offline  
post #3 of 11 Old 04-30-2013, 04:12 PM
Compression Ignition Addict
 
Bryce18's Avatar
 
Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,287
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 141
Thanked 24 Times in 19 Posts
Feedback Score: 0 reviews
When was last time you changed fuel filter?

Sent from AutoGuide.com Free App



'11 F250, 6.7 PSD, 3.55 gears, FX4 CC,SB,KR,5% tint, Hankooks w/ moto metal 959's, B&W hitch
Mods
S&B CAI
H&S MINI
5" mbrp strait pipe
H&S EGR block offs
VIAIR OBA
U.P.train horns

Bryce
Bryce18 is offline  
post #4 of 11 Old 04-30-2013, 05:14 PM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2008
Location: Cypress TX
Posts: 1,107
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 1 reviews
7000 of so miles ago. I just changed it right now, we will see if it helps.

2012 F-250 6.7L 4x4 Lariat CCSB, Titan 51gal, BDS 4" kit with Fox Shox, Toyo AT II 35/12.50R20, Ranch Hands front and rear

2007 F-150 King Ranch 4x4 2" Autospring, Bilstein 5100s on all four corners. Nitto A/T 285s.

2005 Chevy Tahoe 5.3l 2WD
wreedPS is offline  
post #5 of 11 Old 04-30-2013, 05:20 PM
Compression Ignition Addict
 
Bryce18's Avatar
 
Join Date: Oct 2011
Location: Kings River Nevada
Posts: 1,287
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 141
Thanked 24 Times in 19 Posts
Feedback Score: 0 reviews
I think this might solve your problem. I noticed mine was starting to whine a little bit in January right before I changed my fuel filter.

Sent from AutoGuide.com Free App



'11 F250, 6.7 PSD, 3.55 gears, FX4 CC,SB,KR,5% tint, Hankooks w/ moto metal 959's, B&W hitch
Mods
S&B CAI
H&S MINI
5" mbrp strait pipe
H&S EGR block offs
VIAIR OBA
U.P.train horns

Bryce
Bryce18 is offline  
post #6 of 11 Old 04-30-2013, 05:27 PM
Powerstroke.org Fanatic
 
Join Date: Apr 2013
Posts: 130
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 10
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Mine whines now and my truck only has 1,100 miles on it.
FMKeith is offline  
post #7 of 11 Old 05-11-2013, 05:49 PM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2008
Location: Cypress TX
Posts: 1,107
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 1 reviews
Ya my truck is still doing it even after filter change. I guess I just never noticed it. I have no problems with starting and the truck runs great. I also use powerservice regularly.

Oh well. I wont worrry about it for now.

2012 F-250 6.7L 4x4 Lariat CCSB, Titan 51gal, BDS 4" kit with Fox Shox, Toyo AT II 35/12.50R20, Ranch Hands front and rear

2007 F-150 King Ranch 4x4 2" Autospring, Bilstein 5100s on all four corners. Nitto A/T 285s.

2005 Chevy Tahoe 5.3l 2WD
wreedPS is offline  
post #8 of 11 Old 05-11-2013, 05:57 PM
Compression Ignition Addict
 
Join Date: Sep 2012
Location: Clearwater, FL
Posts: 184
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 6 Times in 6 Posts
Feedback Score: 0 reviews
The only time I hear my pump whine is when is extremely low on fuel. And it will whine until I top off. It then goes away.


'11 F350 6.7L FX4,
H&S Tuned & Deleted!
5" Flo-Pro
S&B Intake
Balla6.7 is offline  
post #9 of 11 Old 05-11-2013, 05:58 PM Thread Starter
Compression Ignition Addict
 
Join Date: Oct 2008
Location: Cypress TX
Posts: 1,107
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 1 reviews
Mine does not whine once running, only when you turn the key to the ON position to let glo plug light for a few seconds. If I leave the key there I can hear it whine for a long time or until I fire up.

2012 F-250 6.7L 4x4 Lariat CCSB, Titan 51gal, BDS 4" kit with Fox Shox, Toyo AT II 35/12.50R20, Ranch Hands front and rear

2007 F-150 King Ranch 4x4 2" Autospring, Bilstein 5100s on all four corners. Nitto A/T 285s.

2005 Chevy Tahoe 5.3l 2WD
wreedPS is offline  
post #10 of 11 Old 05-13-2013, 11:35 AM
Compression Ignition Addict
 
Join Date: May 2010
Posts: 198
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 11
Thanked 4 Times in 4 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by wreedPS View Post
Mine does not whine once running, only when you turn the key to the ON position to let glo plug light for a few seconds. If I leave the key there I can hear it whine for a long time or until I fire up.
Same here.

1stgear is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome