Anyone else getting turbo surge? - Ford Powerstroke Diesel Forum
General 6.7 Discussion General 6.7 Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-10-2013, 02:38 PM
Powerstroke.org Fanatic
 

Join Date: Jun 2009
Posts: 120
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Anyone else getting turbo surge?

I just recently deleted with a DPF delete, H&S mini, & EGR delete. I also have an S&B intake. Well every once in a while ill get some turbo surge like I used to on my old 7.3. It usually only happens when I'm barely getting into it to speed up, or I let off the gas quick.

I know the turbos on the 11s are bad, and some on the 12s as well. I didn't know if this was part of the problem with the turbos or if it is just like on the 7.3 with just an annoying bark. I don't want to have the warnings of a bad turbo, and not know what I am looking for.

I know on the 7.3 they had a new compressor wheel to fix the problem and add a little boost. Has anyone heard of anyone doing one of these for our turbos?


Sent from my iPhone using AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-10-2013, 03:45 PM
Member
 

Join Date: Dec 2012
Location: Golden, CO
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well, the compressor surge when letting off of the throttle could be solved by maybe replacing the Recirc. valve. As far as the under-load surge, i'm not sure given my unfamiliarity with the turbos.

Does it still do it under lower boost? Have you replaced any piping?
Reply With Quote Quick reply to this message
  #3  
Old 01-10-2013, 04:33 PM
Powerstroke.org Fanatic
 

Join Date: Jun 2009
Posts: 120
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No piping has been replaced, and yes it is usually at low boost.


Sent from my iPhone using AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #4  
Old 01-10-2013, 05:12 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Location: Ogden, UT
Posts: 2,475
Thanks: 1
Thanked 6 Times in 4 Posts
Feedback Score: 0 reviews
Now your scaring me... I have noticed it twice on mine. First time I noticed it was on the freeway cruising at 65 MPH and I could hear the engine surging. Looked at the boost PSI and it was bouncing from 5-8 PSI back and forth. Did this for about 30 seconds (felt like an eternity). It stopped after I let off the gas for a second and then gave it some throttle to about 15 PSI. Then it settled back down at a constant 6.

2nd time was right after a regen started. 40 MPH cruise set, did it for about 30 seconds again and stopped.

I am all stock and under warrenty till 100K on the motor/turbo right?

Painted horse where are you? We need your knowledge...
Reply With Quote Quick reply to this message
  #5  
Old 01-10-2013, 05:15 PM
Member
 

Join Date: Dec 2012
Location: Golden, CO
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like a turbo-dynamics issue. Try resetting the tune?
Reply With Quote Quick reply to this message
  #6  
Old 01-10-2013, 05:29 PM
Powerstroke.org Fanatic
 

Join Date: Jun 2009
Posts: 120
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
[QUOTE=BIG Laing;3520641]Now your scaring me... I have noticed it twice on mine. First time I noticed it was on the freeway cruising at 65 MPH and I could hear the engine surging. Looked at the boost PSI and it was bouncing from 5-8 PSI back and forth. Did this for about 30 seconds (felt like an eternity). It stopped after I let off the gas for a second and then gave it some throttle to about 15 PSI. Then it settled back down at a constant 6.

2nd time was right after a regen started. 40 MPH cruise set, did it for about 30 seconds again and stopped.

I am all stock and under warrenty till 100K on the motor/turbo



Yeah that's about the same as what mine is doing.

You should still be under warranty, so I would take it in and ask. It couldn't hurt to ask. Maybe the answer could ease all our minds.


Sent from my iPhone using AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #7  
Old 01-10-2013, 05:30 PM
Powerstroke.org Fanatic
 

Join Date: Jun 2009
Posts: 120
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by brstanle View Post
Sounds like a turbo-dynamics issue. Try resetting the tune?
I may try that tomorrow when I'm putting my EGT kit on.


Sent from my iPhone using AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #8  
Old 01-10-2013, 06:10 PM
Member
 

Join Date: Dec 2012
Location: Golden, CO
Posts: 53
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If it's something like a Boost Control Solenoid, resetting the ECU will be a good place to start, definitely a hell of a lot cheaper/ easier than buying or swapping parts.
Reply With Quote Quick reply to this message
  #9  
Old 01-10-2013, 10:14 PM
Compression Ignition Addict
 

Join Date: Sep 2012
Location: Ogden, UT
Posts: 2,475
Thanks: 1
Thanked 6 Times in 4 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by HPUyellowjacket View Post


Yeah that's about the same as what mine is doing.

You should still be under warranty, so I would take it in and ask. It couldn't hurt to ask. Maybe the answer could ease all our minds.


Sent from my iPhone using AutoGuide.com Free App
I will take it in saturday afternoon, and see what they say.
Reply With Quote Quick reply to this message
  #10  
Old 01-11-2013, 01:01 AM
Compression Ignition Addict
 

Join Date: Nov 2011
Posts: 564
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
You aren't running a KEM tune are you? My boost oscillated like crazy with the KEM tunes in there. Got rid of that tune and it ran fine.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors