Turbo question? - Ford Powerstroke Diesel Forum
General 6.7 Discussion General 6.7 Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-16-2012, 04:56 PM
Member
 

Join Date: Aug 2012
Posts: 38
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Turbo question?

I have read in several threads that the trucks that were first built with the 6.7 are having problems with the turbos, they fixed it on the 2012-13 model trucks....is this something to be worried about, i mean how many failures have you guys heard of or experienced. i have a 2011 with 25k on it and i love the truck just would like a heads up on some things about it.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-16-2012, 05:15 PM
Compression Ignition Addict
 

Join Date: Feb 2012
Posts: 279
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by lilman-bigstroke View Post
I have read in several threads that the trucks that were first built with the 6.7 are having problems with the turbos, they fixed it on the 2012-13 model trucks....is this something to be worried about, i mean how many failures have you guys heard of or experienced. i have a 2011 with 25k on it and i love the truck just would like a heads up on some things about it.
Someone in another thread had a good theory about the shaft balance and why it seemed to be causing issues. I believe the oiling system has been blamed for several failures as well. I've decided not to tune this truck due to this issue, at least for a long time. If something were to happen to the motor and I had to pay for it, I'd never hear the end of it from my old lady.
Reply With Quote Quick reply to this message
  #3  
Old 08-16-2012, 05:20 PM
Member
 

Join Date: Aug 2012
Posts: 38
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Same boat i'm in lol
Reply With Quote Quick reply to this message
  #4  
Old 08-16-2012, 06:39 PM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Central Iowa
Posts: 347
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have a Job 1, 2011 that I purchased in 2010 when the 11 model year first came out. I have 30,000 miles on mine, and close to 25,000 with H&S Mini Maxx, and full delete (egr, dpf, scr, urea), and knock on wood, I have had 0 issues either transmission or turbo related. I always let my truck idle for a few minutes when I stop driving before I shut off the engine, I let the EGT's get down to around 250 or lower. And knock on wood, as long as I take care of it, there will never be an issue!
Reply With Quote Quick reply to this message
  #5  
Old 08-16-2012, 07:03 PM
Member
 

Join Date: Aug 2012
Posts: 38
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I agree, my last truck had a turbo timer on it, i would like to get one installed on this rig.
Reply With Quote Quick reply to this message
  #6  
Old 08-16-2012, 07:53 PM
Compression Ignition Addict
 

Join Date: Sep 2009
Posts: 187
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by Hawkeye Diesel View Post
I have a Job 1, 2011 that I purchased in 2010 when the 11 model year first came out. I have 30,000 miles on mine, and close to 25,000 with H&S Mini Maxx, and full delete (egr, dpf, scr, urea), and knock on wood, I have had 0 issues either transmission or turbo related. I always let my truck idle for a few minutes when I stop driving before I shut off the engine, I let the EGT's get down to around 250 or lower. And knock on wood, as long as I take care of it, there will never be an issue!

How hard was it to put a guage on it for the EGT's? Wouldn't mind having one
Reply With Quote Quick reply to this message
  #7  
Old 08-17-2012, 01:23 PM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Central Iowa
Posts: 347
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Jason1Pa View Post
How hard was it to put a guage on it for the EGT's? Wouldn't mind having one
When you do the full deletes, one of the EGR block off plates comes with a well welded in it so you can install one of the pyro probes from your factory exhaust into your block. It wasn't too hard at all.
Reply With Quote Quick reply to this message
  #8  
Old 08-19-2012, 06:13 PM
Powerstroke.org Rookie
 

Join Date: Aug 2012
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does any one have problems with their turbos pulsating?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:16 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors