Returned it back to stock and now... - Ford Powerstroke Diesel Forum
General 6.7 Discussion General 6.7 Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-25-2012, 01:58 PM
Member
 

Join Date: Jun 2011
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Returned it back to stock and now...

Has anyone turned their tuned and deleted 6.7 completely back to stock? I just did today because I couldn't make myself fall in love with the tune. It's a SO much smoother truck stock. Now I'm getting a CEL. It says EGR control valve stuck open. I'm just wondering if anyone else has had this problem after returning to stock.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-25-2012, 02:46 PM
Powerstroke.org Fanatic
 

Join Date: Oct 2010
Location: Bakersfield, CA
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What tune did you have If it was the h&s I felt the same way until I updated it friday. Now its alot smoother and dosent lug when just crusing. The tune I had was .17 now its .19 hope this helps.
Reply With Quote Quick reply to this message
  #3  
Old 03-25-2012, 02:51 PM
Member
 

Join Date: Jun 2011
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was a mini maxx. I didn't try the new update. I'm just gonna try it stock again for awhile.
Reply With Quote Quick reply to this message
  #4  
Old 03-25-2012, 02:59 PM
Compression Ignition Addict
 

Join Date: Dec 2010
Location: Central Iowa
Posts: 347
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Someone else on this forum had their truck tuned, and returned it to stock, and had the same issue if I recall correctly... They took their truck in and had to have their EGR replaced by ford, and I think it was all taken care of under warranty.
The EGR on a 6.7 does not cycle through like on a 6.4, so you typically get alot of soot build up on it.
Reply With Quote Quick reply to this message
  #5  
Old 03-25-2012, 03:00 PM
Powerstroke.org Fanatic
 

Join Date: Oct 2010
Location: Bakersfield, CA
Posts: 106
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I noticed how hard it shifted and how fast it would go through the gears wich would make it lug when not puting your foot into it. I had just installed mine 2 weeks ago and I was ready to go back to stock. I decided to call H&S and let them know I was unhappy with there tune they said they where working on a new overdrive tune and that it would clean all of that jumpy sh-t up. It did I downloaded friday and I am very pleased with the programer now. everthing seems to be runing and working great.
Reply With Quote Quick reply to this message
  #6  
Old 03-25-2012, 03:58 PM
Member
 

Join Date: Jun 2011
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I might have to try it with dpf on. I'm going to get this EGR problem taken care of first. I guess it will have to go to Ford tomorrow.
Reply With Quote Quick reply to this message
  #7  
Old 03-25-2012, 05:46 PM
Compression Ignition Addict
 

Join Date: Sep 2009
Location: Vegreville, Alberta, Canada
Posts: 417
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Did you unplug the 2 egr valves under the hood when u had the truck tuned?
Reply With Quote Quick reply to this message
  #8  
Old 03-25-2012, 05:50 PM
Member
 

Join Date: Jun 2011
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by AlbertaStroker View Post
Did you unplug the 2 egr valves under the hood when u had the truck tuned?
No I left everything plugged in.
Reply With Quote Quick reply to this message
  #9  
Old 03-25-2012, 05:52 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2012
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Hawkeye Diesel View Post
Someone else on this forum had their truck tuned, and returned it to stock, and had the same issue if I recall correctly... They took their truck in and had to have their EGR replaced by ford, and I think it was all taken care of under warranty.
The EGR on a 6.7 does not cycle through like on a 6.4, so you typically get alot of soot build up on it.

I just had my egr deleted, it was exceptionally clean even with the high miles. I inspected it and was impressed!! I was told it is not positioned the same as the 6.4, my ignorance as to what the difference is...however it is clean!! Surprisingly.
Reply With Quote Quick reply to this message
  #10  
Old 10-03-2012, 03:16 AM
Member
 

Join Date: Feb 2012
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Any update? I returned to stock, and now get the same cel.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:44 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors