Factory Sway Bar End Links - Ford Powerstroke Diesel Forum
General 6.7 Discussion General 6.7 Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-29-2011, 04:47 AM
Compression Ignition Addict
 

Join Date: Oct 2008
Posts: 189
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Factory Sway Bar End Links

Has anyone lifted their truck and replaced the factory sway bar end links?

I need a set of the factory ones for my truck. The aftermarket ones on my truck do not fit right and I want to go back with the factory ones to get the correct clearence.

Anyone willing to part with their factory ones let me know.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-29-2011, 06:01 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 691
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
If They don't fit right ,i would get with Who ever you bought then From and let them Worry about making it Right!

Besides they Need to Know theres an Issue so they can Correct it for other Kits...

Whats not fitting Right? Is the Bolt shaft to small or something? If so maybe you can Sleeve it ?

But it Should be Plug and Play as they say,so i would make them get it Right!
Reply With Quote Quick reply to this message
  #3  
Old 03-29-2011, 06:12 AM
Compression Ignition Addict
 

Join Date: Oct 2008
Posts: 189
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
The sway bar end link is rubbing the the lower tie rod end when I turn the wheel all the way it is like a slight grind. It has not been a big deal, but it sure is annoying when your driving such a pricey vehicle.

I agree they should make it right. I have a warranty for three years on the lift so they better fix it!
Reply With Quote Quick reply to this message
  #4  
Old 03-29-2011, 07:26 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Posts: 691
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I would Just Notch the lower tie rod end so it don't touch

I'm with you,If any issues come up with the lift i wouldn't pay more to get it right!They would get it right....

This way they can improve what they sale,They want know theres and issue unless someone tells them,all trucks are not the same so one lift may Rub when another may not....

I'm sure they will be glad to get your truck right,specially with it showing off their product...

Sweet Truck by the way!
Reply With Quote Quick reply to this message
  #5  
Old 03-29-2011, 08:31 AM
Compression Ignition Addict
 

Join Date: Oct 2008
Posts: 189
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Thanks bud appreciate it.

It has been a frustrating process with this dang sway bar. I spoke to 4wheel parts a few times and they tried a few adjustments and it made it better but then it still did not fix it completeley. I then talked to an Engineer at ProComp about it so now they are trying to manufacture a bracket to adjust the end link so it does not rub. It has been a work in progress since they don't make this lift for a 2011. Hopefully I will get a resolution soon. They said if not they will take the lift back and send me a Fabtech 4 link coil over kit so one way or another Ill get a solution!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:20 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors