AVS in channel Vent Visors? - Ford Powerstroke Diesel Forum
General 6.7 Discussion General 6.7 Discussion

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-20-2011, 06:58 AM
Member
 

Join Date: Apr 2010
Posts: 47
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
AVS in channel Vent Visors?

Has anyone with these visors installed had issues with them scratching their tent at the top of the windows? I'm about to purchase a set and just want to make sure I won't have any issues.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-20-2011, 07:00 AM
Compression Ignition Addict
 

Join Date: Nov 2009
Location: Ruidoso, NM
Posts: 1,649
Thanks: 0
Thanked 7 Times in 7 Posts
Feedback Score: 0 reviews
i dont have any on this truck, but i have them on my other truck and they scratched the tops of my tint pretty good
Reply With Quote Quick reply to this message
  #3  
Old 03-20-2011, 07:40 AM
Premium Member

 

Join Date: Dec 2010
Location: Pinckney, Michigan
Posts: 57
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Skype™ to gldubzakjr
I have the Weathertech ones and have used them on multiple vehicles without any issues. The tint peels back because of poor tinting techniques by the installer, it happened once to me and I have not had an issue since, no tint peeling so long as your cautious for a few days and leave the windows closed after tinting and again after installing the window guards...
Reply With Quote Quick reply to this message
  #4  
Old 03-20-2011, 12:44 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Posts: 612
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the channel ones...either my lousy install job or...??? I pulled em off because of wind noise where the window channel formed around the plastic, and every once in a while the window would catch it when closing, I trashed em and put on the external mounted ones.

I am still waiting for a bug shield to get produced...
Reply With Quote Quick reply to this message
  #5  
Old 03-21-2011, 10:14 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Location: Edmonton, Alberta, Canada
Posts: 1,404
Thanks: 3
Thanked 24 Times in 20 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by richc22a View Post
I had the channel ones...either my lousy install job or...??? I pulled em off because of wind noise where the window channel formed around the plastic, and every once in a while the window would catch it when closing, I trashed em and put on the external mounted ones.

I am still waiting for a bug shield to get produced...
agreed! the wind noise with those is greatly increased
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:16 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors