Help- guys with AMP steps. - Ford Powerstroke Diesel Forum
General 6.7 Discussion (2011-2016) General 6.7 Discussion

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 Old 12-28-2012, 12:58 PM Thread Starter
Powerstroke.org Fanatic
 
HPUyellowjacket's Avatar
 
Join Date: Jun 2009
Posts: 122
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Help- guys with AMP steps.

Well what I worried about when I put the steps on finally happened. I was driving on the ranch after it snowed the other day, and had to drive through some mud. I went and sprayed the steps off as well as under the truck.
Well now the steps won't go all the way up, and act as if there is something in the way. There is no mud left, and nothing that I can see causing an obstruction.
Has anyone had this problem? If so, what can I do to fix the steps?


Sent from my iPhone using AutoGuide.com Free App

New Truck
2012 Lariat FX4 Off Road, Tuxedo black, Custom paint to match grille, paint to match halo projector headlights, S&B intake, Amp Steps, RBP 94R black with chrome insert 20X9 wheels, 35 Nitto Trail grapplers

The Toy
2001 4x4 off-road extended cab, DP tuner, 4 inch turbo back, S&B filter, smoked projector headlights, Ranch hand fron & rear replacements, 18 inch fuel wheels, nitto trail grapplers.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HPUyellowjacket is offline  
Sponsored Links
Advertisement
 
post #2 of 18 Old 12-28-2012, 02:08 PM
Powerstroke.org Rookie
 
Join Date: May 2012
Posts: 29
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
take them off and sell them to me
mchottie is offline  
post #3 of 18 Old 12-28-2012, 02:27 PM
Compression Ignition Addict
 
KAKnight's Avatar
 
Join Date: Aug 2012
Posts: 435
Thanks: 0
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Or me lol. Is it both steps or just one? If its just one, then I could be a small rock or something in the gears. If its both, then could be an electrical issue. Maybe let it dry out and could fix itself.


Sent from my iPhone using AutoGuide.com App
KAKnight is offline  
post #4 of 18 Old 12-28-2012, 03:07 PM
Member
 
Profarm72's Avatar
 
Join Date: Oct 2012
Location: Watauga, Texas
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Subscribing.

I've been thinking about getting these steps for my truck, hope you get it figured out.


Sent from my iPhone using AutoGuide.com Free App

2009 F250 FX4 * H&S MINI MAXX WITH HD300 TUNE * 4" STRAIGHT PIPE TURBO BACK * BANKS CAI * EGR/COOLER DELETE * RANCH HAND * LIFTED W/35's * WITH MORE MODS TO COME.
Profarm72 is offline  
post #5 of 18 Old 12-28-2012, 03:40 PM Thread Starter
Powerstroke.org Fanatic
 
HPUyellowjacket's Avatar
 
Join Date: Jun 2009
Posts: 122
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yes it's both steps. I'm hoping its nothing to big. I really don't want to have to go through them to fix them.


Sent from my iPhone using AutoGuide.com Free App

New Truck
2012 Lariat FX4 Off Road, Tuxedo black, Custom paint to match grille, paint to match halo projector headlights, S&B intake, Amp Steps, RBP 94R black with chrome insert 20X9 wheels, 35 Nitto Trail grapplers

The Toy
2001 4x4 off-road extended cab, DP tuner, 4 inch turbo back, S&B filter, smoked projector headlights, Ranch hand fron & rear replacements, 18 inch fuel wheels, nitto trail grapplers.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HPUyellowjacket is offline  
post #6 of 18 Old 12-28-2012, 08:37 PM
Member
 
Join Date: Aug 2012
Posts: 81
Thanks: 0
Thanked 5 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Sounds like they lost track of their position on the controller. Maybe disconnect power to the controller and reconnect.

I've run mine through some snow and mud recently and a lot of rain, no issues.
Hopeless Diamond is offline  
post #7 of 18 Old 12-29-2012, 08:35 AM Thread Starter
Powerstroke.org Fanatic
 
HPUyellowjacket's Avatar
 
Join Date: Jun 2009
Posts: 122
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Hopeless Diamond View Post
Sounds like they lost track of their position on the controller. Maybe disconnect power to the controller and reconnect.

I've run mine through some snow and mud recently and a lot of rain, no issues.
Yeah that did it. I have taken them through mud and anything imaginable already so I was really confused when they decided not to work this time. Thanks for the help.


Sent from my iPhone using AutoGuide.com Free App

New Truck
2012 Lariat FX4 Off Road, Tuxedo black, Custom paint to match grille, paint to match halo projector headlights, S&B intake, Amp Steps, RBP 94R black with chrome insert 20X9 wheels, 35 Nitto Trail grapplers

The Toy
2001 4x4 off-road extended cab, DP tuner, 4 inch turbo back, S&B filter, smoked projector headlights, Ranch hand fron & rear replacements, 18 inch fuel wheels, nitto trail grapplers.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HPUyellowjacket is offline  
post #8 of 18 Old 12-29-2012, 09:25 AM
Compression Ignition Addict
 
outlaw507's Avatar
 
Join Date: Aug 2009
Location: Cumming Ga
Posts: 171
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Check all the wires where they plug into the controller. My passenger side would work one time and not the next. There was a loose wire in the plug at the controller

2007 outlaw. All stock no mods at all!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
outlaw507 is offline  
post #9 of 18 Old 12-29-2012, 09:52 AM
Member
 
Join Date: Aug 2012
Posts: 81
Thanks: 0
Thanked 5 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by HPUyellowjacket View Post
Yeah that did it. I have taken them through mud and anything imaginable already so I was really confused when they decided not to work this time. Thanks for the help. Sent from my iPhone using AutoGuide.com Free App
Glad to hear there are still simple fixes to problems. I never seem to get those kind of problems but it's good to hear they do exist
Hopeless Diamond is offline  
post #10 of 18 Old 12-30-2012, 02:52 PM
Premium Member

 
Bullitt1289's Avatar
 
Join Date: Nov 2012
Location: Abilene
Posts: 170
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Subscribed. Hope you get them fixed! I'm ordering some for my truck as soon as I get it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

13 F250 FX4 CC Lariat Blue jean metallic
01 Mustang Bullitt #1289
02 F250 XLT 7.3 (sold)

SSgt USAF
Bullitt1289 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome