just bought 08 f250 6.4 - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-02-2013, 07:54 AM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
just bought 08 f250 6.4

Hey yall, I just bought a 2008 f250 4x4 lariat. the truck has a 6.4l obviously, and has 180,000 on it. I know the milage seems high but I got a good deal and from what I can tell the truck has been really well maintained. I have a couple of questions though. first off it has a programmer on it. what kind I don't know because I do not have the actuall programmer. what I do know is that it makes a ton of power and seems to be happy with exception to 2 things. first it says check air filter when I start it up. not sure if its not getting enough airflow or not. it is a stock filter. secondly and this just started, my truck keeps killing the batteries. in the morning they are almost completely dead. or anytime after I shut it off. if I jump it the truck runs great, so I don't think its the alternator. bad cell in the battery maybe? and funally how can I tell whats been done to this truck as far as "bulletproofing" goes? i.e. egr delete etc. my first thought is if the truck has 180000 if it had a ton of issues they would have shown up by now right? thank you for your advice input and time
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-02-2013, 08:47 AM
Premium Member
 

Join Date: Apr 2012
Posts: 990
Thanks: 2
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
if it has the stock air filter it may have an issue with the extra power. sometimes it will screw up....also there is a reset button thingy on your air filter also. may check that does it have exhaust by chance..straight pipe from the front to the back?
Reply With Quote Quick reply to this message
  #3  
Old 09-02-2013, 09:00 AM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm not real sure on what exhaust it has. The tips are stock but it definitely doesnot have stock exhaust. Where is the reset button for the air filter?
Reply With Quote Quick reply to this message
  #4  
Old 09-02-2013, 09:42 AM
Premium Member
 

Join Date: Apr 2012
Posts: 990
Thanks: 2
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
find the air filter box and you should see it in that area. theres a piece that has red and yellow or something like that....it may not be a reset button, but its an indicator of your filter
Reply With Quote Quick reply to this message
  #5  
Old 09-02-2013, 11:24 AM
Member
 

Join Date: Apr 2013
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by THE BIG FISH View Post
I'm not real sure on what exhaust it has. The tips are stock but it definitely doesnot have stock exhaust. Where is the reset button for the air filter?
It's a filter minder on your intake tube, people running 250+ tunes have problems with it sucking in the filter minder.
Reply With Quote Quick reply to this message
  #6  
Old 09-02-2013, 11:31 AM
Compression Ignition Addict
 

Join Date: Jun 2013
Posts: 358
Thanks: 7
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Mine does this. It's a blue reset button
Reply With Quote Quick reply to this message
  #7  
Old 09-02-2013, 04:25 PM
Powerstroke.org Rookie
 

Join Date: Sep 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the info, any ideas on the battery problem. It was fine for like the first 2 weeks, now every time I shut it off the batteries are dea
d.
Reply With Quote Quick reply to this message
  #8  
Old 09-02-2013, 06:46 PM
Compression Ignition Addict
 

Join Date: Jun 2013
Posts: 358
Thanks: 7
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Have you had the batteries checked?
Reply With Quote Quick reply to this message
  #9  
Old 09-02-2013, 11:35 PM
Member
 

Join Date: Apr 2013
Posts: 63
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by THE BIG FISH View Post
Thanks for the info, any ideas on the battery problem. It was fine for like the first 2 weeks, now every time I shut it off the batteries are dea
d.
Load test the batteries.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:17 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors