2008 fuel gauge always full - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-05-2013, 07:09 AM
Compression Ignition Addict
 

Join Date: Feb 2012
Location: Canton, Ga
Posts: 559
Thanks: 9
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
2008 fuel gauge always full

I've done some searching on here and I seem to have the opposite problem from most people on here. The gauge in my truck (2008 F-250, 6.4, base model) doesn't move off of full. It started a couple of weeks ago when I was showing a half a tank and then as I was driving I started watching it move back towards full. I let it get to full and then I stopped and opened up the fuel cap. It was hissing like I was taking a radiator cap off. I put it back on and started the truck up, now I was showing the half a tank agian. It worked properly on and off for for a week or two and now it doesn't move at all. Yesteraday I filled up, drove over 400 miles, and the gauge never moved. When I stopped to fill up agian I took the fuel cap off and it started hissing like it has been, but this time I heard something else coming from under the truck. I can't say for sure what it was, but it sounded to me like the tank contracting. I assume the tank isn't venting properly, but before I dive into this has anyone every expierence anything like this?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-06-2013, 11:07 AM
Compression Ignition Addict
 

Join Date: Feb 2012
Location: Canton, Ga
Posts: 559
Thanks: 9
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Getting a lot of views. No one's ever been through this?
Reply With Quote Quick reply to this message
  #3  
Old 07-06-2013, 04:32 PM
Compression Ignition Addict
 

Join Date: Apr 2010
Location: San antonio TX
Posts: 1,243
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Well I haven't been through this with my truck but I have been through it with 2 other cars and it was a bad sending unit both times.


Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:14 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors