AC Help - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-07-2013, 02:39 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2013
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
AC Help

I was having problems with my air conditioner and at a shop it was diagnosed with an AC Control Head problem. The AC would not blow at all. Since then the truck has had a new Control Head, AC Relay, and Blower Motor Controller/Resistor. Found out the problem was the Blower Motor. Now the AC will blow one speed, will not change from the front vents to floor or defrost and will not turn off unless I turn the truck off. The truck is an 08 F-250 6.4 PSD CC SB. Dual climate control AC with heated seats. Please help.


Sent from AutoGuide.com App
ian_hester06 is offline  
post #2 of 4 Old 06-08-2013, 10:48 AM
Member
 
flashover1969's Avatar
 
Join Date: Oct 2012
Location: Arizona
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to flashover1969
This is really a tough one (for me at least). When you have the dual climate controls and the electronic servos that control the blend doors it can be a huge problem to find the issues with this. Something I've done in the past with a vehicle that was equipped with a similar system was disconnect the battery for about 30 minutes. This caused the electronics with the ac system to "reset" and it helps ou my problem at the time. The problem for me was the passenger side would only blow out hot air when the ac was on. After the reset it went back to working normal. Who knows this might help you but I really don't know.
I would your only other option is take it to another shop.
flashover1969 is offline  
post #3 of 4 Old 06-08-2013, 08:08 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2013
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
That was the last thing we tried. Maybe a reflash at the dealership to reset the CPU?


Sent from AutoGuide.com App
ian_hester06 is offline  
post #4 of 4 Old 06-08-2013, 08:09 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Apr 2013
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Thanks for the input.


Sent from AutoGuide.com App
ian_hester06 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome