Motor went haywire, redlined, then shut down. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-23-2013, 03:02 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2012
Location: Findlay
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Motor went haywire, redlined, then shut down.

Ok everybody. What would happen if gas got in diesel. My truck just went haywire 5 miles from the fuel station. It was like the accelerator stuck wide open, then the exhaust turned whitish grayish, then the I turned the key off and it wouldn't shut down! I was approaching 80 so I thru it in nuetral bc I was on a county road. It wrapped out at 5000+rpm then finally shut off. There's oil and fuel all down the passenger side and its definitely FUBAR. this truck has been perfectly fine until this. I'm having it towed to a shop here in Findlay OH and having them test the fuel first thing. If it's not fuel what could've happened?!




Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-23-2013, 05:45 PM
Compression Ignition Addict
 

Join Date: Sep 2010
Posts: 1,706
Thanks: 1
Thanked 16 Times in 16 Posts
Feedback Score: 0 reviews
Sounds like it run away on you bud. Have you checked the oil level to make sure the crankcase wasnt full of oil and fuel?
Reply With Quote Quick reply to this message
  #3  
Old 05-23-2013, 06:25 PM
Powerstroke.org Fanatic
 

Join Date: Dec 2012
Location: Findlay
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm deleted and I've only out 2500 miles on since I've bought it. I changed the oil when I got it home and check it almost every time I drive it. Is this common? Or I guess has it happened to people before??


Sent from AutoGuide.com App
Reply With Quote Quick reply to this message
  #4  
Old 05-23-2013, 06:25 PM
Premium Member
 

Join Date: Oct 2012
Posts: 594
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like oil got in the combustion chamber and was a run away, checo if your turbos are blown, oil could have went through them and ended up in the chamber, or just a simple over fill of oil, and motor went boom, or you something else, sorry bud!!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:40 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors