No power and no boost - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-30-2007, 03:57 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No power and no boost

Ok this is what I have. 2008 f-250 6.4 auto trans 8500 miles job 1 truck.

here is the whole story.

Yesterday afternoon I lightly washed my engine. ( engine was cold) I let it dry off for 30 minutes before I drove it to the store. When I pulled back in my drive way and put it in park it started regenerating. I let it idle and regenerate for a good 30 minutes.

Today I leave and after its warmed up I went and stepped on it to pass a car. Well when I went to pass a car my tack slowly went to 3k and my boost slowly went to right under 10 pounds. The speedo took for ever to get passed 30 mph. Truck has no power whats so ever and it sounds a little loder than normal . Any ideas ? I came to the conclusion that I either blew a turbo out or have a issue with the dpf ?

I did just notice that my check engine lights on. I also checked all my hoses/boots from my intercooler to my turbo
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-30-2007, 04:34 PM
Compression Ignition Addict
 

Join Date: Mar 2007
Location: Birmingham area Alabama
Posts: 341
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine did this and the rod to the waste gate from the controller had broken off, just a thought.
Reply With Quote Quick reply to this message
  #3  
Old 12-30-2007, 06:04 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by richardndawnc View Post
mine did this and the rod to the waste gate from the controller had broken off, just a thought.
not to sound dumb but is this something I can fix myself tonight or do i need to take it to the dealer ? were is the waste gate and controler ?

thanks for the help
Reply With Quote Quick reply to this message
  #4  
Old 12-30-2007, 06:11 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Magdalena NM
Posts: 525
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I bet Richard is right, I can't see any reason why a light wash could do this, unless you got your PCM wet or something else electrical. Good luck!
Reply With Quote Quick reply to this message
  #5  
Old 12-30-2007, 08:11 PM
Compression Ignition Addict
 

Join Date: Mar 2007
Location: Birmingham area Alabama
Posts: 341
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by longshooter View Post
not to sound dumb but is this something I can fix myself tonight or do i need to take it to the dealer ? were is the waste gate and controler ?

thanks for the help
It is just straight forward standing in front of the Ford emblem, look to the back towards thefirewall beside the turbo housing (slightly to your right) under the black cowling grill. Its a shiny rod that has 2 end links on it that connects to a arm on each end , look to see if it is hooked up on both ends and if it is then it is not the problem. I had to replace the controler on mine since the housing had broken off. I hope this helps, if not find out what the code is and we can go from there.
Reply With Quote Quick reply to this message
  #6  
Old 01-02-2008, 04:59 PM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It ended up being a "EBP" (exhaust back pressure)

I got the truck back earlier today. One thing I noticed was my gas mileage has gone down 3-4 mpg . Is that normal since they probaly had to reset my computer ?
Reply With Quote Quick reply to this message
  #7  
Old 01-03-2008, 09:48 AM
Let's Run'em


 
Join Date: May 2007
Location: El Paso, TX
Posts: 17,661
Thanks: 3
Thanked 13 Times in 12 Posts
Feedback Score: 2 reviews
Send a message via AIM to TwinTurboStroker
Quote:
Originally Posted by longshooter View Post
It ended up being a "EBP" (exhaust back pressure)

I got the truck back earlier today. One thing I noticed was my gas mileage has gone down 3-4 mpg . Is that normal since they probaly had to reset my computer ?
Yeah I would say it is normal, I would give it a tank full to see if the mileage comes back up......now as far as the EBP, that sounds a little odd to me
Reply With Quote Quick reply to this message
  #8  
Old 01-04-2008, 07:46 PM
Compression Ignition Addict
 

Join Date: Mar 2007
Location: Birmingham area Alabama
Posts: 341
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Everytime Ford has ever touched my truck - even for oil change, they always have reflashed the ecm with the newest update and it alwys has dropped MPG for a while.But now with the kem I have the data link coved with a piece of tape and I tell them you reflash it - you owe me a grand !!!
Reply With Quote Quick reply to this message
  #9  
Old 01-07-2008, 07:14 AM
Let's Run'em


 
Join Date: May 2007
Location: El Paso, TX
Posts: 17,661
Thanks: 3
Thanked 13 Times in 12 Posts
Feedback Score: 2 reviews
Send a message via AIM to TwinTurboStroker
Quote:
Originally Posted by richardndawnc View Post
But now with the kem I have the data link coved with a piece of tape and I tell them you reflash it - you owe me a grand !!!
Hahaha thats awesome
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:57 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors