Freaking me out... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-14-2013, 11:26 AM
Premium Member
 

Join Date: Jun 2009
Location: Alabama
Posts: 5,639
Thanks: 1
Thanked 11 Times in 11 Posts
Feedback Score: 9 reviews
Question Freaking me out...

Okay, so my truck has been doing some strange stuff recently. It's just started happening in the past few days, and I think it may just be a tune/computer issue, but not positive. I'm going to retune the computer tonight with the updated H&S files.

So here's where it started. We are all outside detailing a buddy's truck, and all of the sudden, the exterior lights turn on on my truck, and we all walked over there. The alarm light was flashing, and when I opened the door, the dash computer said "Theft Detected - Engine Disabled." Nobody had touched the truck. Luckily, I have a Black Maxx, so I cleared the codes and the engine started up fine.

On the way home, every once in a while (happened two or three times), when I would brake, the dash computer and the radio would turn off, and immediately cut back on. Weird, but it never cut off for more than a second.

Today I get a call from my roommate saying that he can hear my truck blaring the radio from 15-20 feet away. Doors were locked, I was in class. He runs upstairs, grabs my spare key, comes back down a few minutes later, and the radio was off. Really creepy, if you ask me. I will be home in about a half hour to check everything out. Anything I should look for? I had been getting a "Brake Switch Circuit" or some code like that, but that's pretty typical for a tuned truck. Every time that code pops up, the cruise doesn't work until I cycle the key a few times. Typical random problem when tuned.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-14-2013, 11:51 AM
Powerstroke Techie

 

Join Date: Oct 2009
Posts: 1,677
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
NEVER had that brake switch circuit code, and never had a problem with my cruise, and it's been tuned since about 100mi.

I would pull the GEM module out and see if there's any water in it. I realize this was typically a normal problem with earlier models of these trucks, but it's still at the bottom of the pillar and the windshield can piss water in on it if it leaks.

Aside from that, does your truck have aftermarket remote start/alarm system installed?
Reply With Quote Quick reply to this message
  #3  
Old 01-14-2013, 12:00 PM
Premium Member
 

Join Date: Jun 2009
Location: Alabama
Posts: 5,639
Thanks: 1
Thanked 11 Times in 11 Posts
Feedback Score: 9 reviews
Quote:
Originally Posted by Big Angry Hillbilly View Post
NEVER had that brake switch circuit code, and never had a problem with my cruise, and it's been tuned since about 100mi.

I would pull the GEM module out and see if there's any water in it. I realize this was typically a normal problem with earlier models of these trucks, but it's still at the bottom of the pillar and the windshield can piss water in on it if it leaks.

Aside from that, does your truck have aftermarket remote start/alarm system installed?
I've heard of a few other people with H&S tuners having the intermittent cruise outage.

Where exactly can I find the GEM module? It's an August of 2007 built date, so it's a pretty early model.

It does not have an aftermarket alarm. The only thing aftermarket in the interior is the H&S Black Maxx, the Rudy's Pod, and the JVC dual din stereo.
Reply With Quote Quick reply to this message
  #4  
Old 01-14-2013, 12:41 PM
Powerstroke Techie

 

Join Date: Oct 2009
Posts: 1,677
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
It's in the RHS kick panel, if you're sitting in the passenger seat, it's behind the trim panel where your right foot would be.

It's unlikely that this is the issue, but it's possible.

Also, has the cab ever been off this truck before, that you know of? If you don't know send me the VIN and I will see if it was ever off under warranty. Just trying to see if any of the wiring has been unhooked before, maybe a ****ty connection there somewhere.

This is unusual, on a 2008 truck. As for the radio playing by itself, it could be something internal to the radio, so I'm going to address that issue last - I'm scratching my head about the theft detected and lights on/off.

Another thing that comes to mind, is this thing is a KR, so it's got all kinds of bells and whistles, the underhood switch may have an intermittent issue causing it to trigger the alarm.

The other part that has me scratching my head, is you said you cleared the codes.

I imagine you had a P1260 code set.

That is set when the ignition switch is keyed on and the PATS transceiver does not see a valid PATS key signal.

For this happening, I imagine the keys were in your pocket or otherwise not in the truck?

Based on this info, I'd eyeball the ignition switch. Pull the column shroud off and see if someone's been dinking around in there, maybe it's had a remote start/alarm at some point and been removed, or the switch itself is going for a poop.

Hope this can point you in the right direction.
Reply With Quote Quick reply to this message
  #5  
Old 01-14-2013, 01:54 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Ontario
Posts: 1,602
Thanks: 2
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
A buddy was telling me the other day his friends duramax was doing the same thing. Start honking. The horn by itself. Turn the radio on by itself. Ill ask him if he found the issue. The brake switch is under the brake fluid reservoir and causes the cruise control to go out it happened on tuned a d stock trucks very common problem and easy fix
Reply With Quote Quick reply to this message
  #6  
Old 01-14-2013, 03:55 PM
Compression Ignition Addict
 

Join Date: Jul 2010
Location: Cincinnati
Posts: 4,220
Thanks: 6
Thanked 37 Times in 36 Posts
Feedback Score: 13 reviews
The wiring on these trucks are a mess and one issue can make the truck do crazy things my truck would start up and all the check engine lights, tire pressure, abs, traction control(I don't even have traction control) trailer brake fault, check brake system were popping up and the truck would be stuck in 3rd gear and when switching from drive to reverse it would take a couple minutes to engage, the turbo would turn off and it would smoke like a freight train. If you turn it off it won't turn back on until the codes got cleared with my mini maxx. After about a month of it going crazy it started locking my h&s out and wouldn't let me clear the code. My buddy came over with fords computer and wouldn't even let fords software in and he said it trumps everything. Well long story short it ended up being a short in the brake control module causing the CAN/bus system to make all the other modules in the truck go crazy. It was a mess and the dealer had my truck over two weeks trying to find what was causing it. Hope yours is an easier fix

Edit, oh and the stereo, and gauges wouldn't work either.
Reply With Quote Quick reply to this message
  #7  
Old 01-14-2013, 03:57 PM
Premium Member
 

Join Date: Jun 2009
Location: Alabama
Posts: 5,639
Thanks: 1
Thanked 11 Times in 11 Posts
Feedback Score: 9 reviews
Quote:
Originally Posted by travisH3 View Post
The wiring on these trucks are a mess and one issue can make the truck do crazy things my truck would start up and all the check engine lights, tire pressure, abs, traction control(I don't even have traction control) trailer brake fault, check brake system were popping up and the truck would be stuck in 3rd gear and when switching from drive to reverse it would take a couple minutes to engage, the turbo would turn off and it would smoke like a freight train. If you turn it off it won't turn back on until the codes got cleared with my mini maxx. After about a month of it going crazy it started locking my h&s out and wouldn't let me clear the code. My buddy came over with fords computer and wouldn't even let fords software in and he said it trumps everything. Well long story short it ended up being a short in the brake control module causing the CAN/bus system to make all the other modules in the truck go crazy. It was a mess and the dealer had my truck over two weeks trying to find what was causing it. Hope yours is an easier fix

Edit, oh and the stereo, and gauges wouldn't work either.
Hmmmm... maybe this is related to my brake switch code? I believe it is a P0703 or something like that...
Reply With Quote Quick reply to this message
  #8  
Old 01-14-2013, 04:00 PM
Compression Ignition Addict
 

Join Date: Jul 2010
Location: Cincinnati
Posts: 4,220
Thanks: 6
Thanked 37 Times in 36 Posts
Feedback Score: 13 reviews
Quote:
Originally Posted by SickStroke6.0 View Post
Hmmmm... maybe this is related to my brake switch code? I believe it is a P0703 or something like that...
Mine had a laundry list of codes. The only ones I remember is the u0073 which is problem with communication with the can/bus.
Reply With Quote Quick reply to this message
  #9  
Old 01-14-2013, 07:09 PM
Compression Ignition Addict

 

Join Date: May 2012
Location: Broward County
Posts: 641
Thanks: 5
Thanked 4 Times in 3 Posts
Feedback Score: 1 reviews
I could be totally off here, but I do have an anftermarket alarm (you said you don't) and my alarm started doing weird stuff when my batteries in the truck started going bad. Took it to Autozone and both went bad. Replaced them and the truck is fine now. May be worth checking your batteries.
Reply With Quote Quick reply to this message
  #10  
Old 01-14-2013, 08:32 PM
Member
 

Join Date: Jul 2011
Posts: 82
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
my dads 6.4 does weird things too and he kept thinking it was the remotes for the truck. but he'd be sitting in the kitchen at night and all the lights would come on. flashers start flashing and doing all kinds of weird things. this has happended a couple times and he walked outside with his gun one time, because he thought he heard a door open and he thought someone was stealing his truck with all the lights flashing and stuff!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:27 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors