08 6.4's don't like dex-cool - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-22-2012, 10:51 AM
Premium Member
 

Join Date: Oct 2012
Posts: 594
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Angry 08 6.4's don't like dex-cool

Guys my trucks under the gun right now

Yesterday replaced radiator, finally started leaking

Water pump was destroyed, replaced

Checked for catoivation and nothing!!!

Took off radiator and literally chunks of red clay came out.

Degas bottle had chunks... Flushed it 10 times and it runs good...

First time though it was black and crusty on the bottom of the degas bottle... That's normal right!? Coolant didn't have I black oroil whatsoever and oil is not milky..

What can it be?! I'll post pics of truck later
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-22-2012, 10:53 AM
Don't you worry about it

 

Join Date: Jan 2008
Location: North Carolina
Posts: 5,627
Thanks: 2
Thanked 58 Times in 52 Posts
Feedback Score: 0 reviews
Why would you put dex-cool in your truck?
Reply With Quote Quick reply to this message
  #3  
Old 12-22-2012, 11:01 AM
Premium Member
 

Join Date: Oct 2012
Posts: 594
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No i didnt. Recently got flushed by my dads friends.. (i let him borrow the truck) saw the coolant bottle and instantly knew it was dex-cool. Ignored it found a thread about it Thursday and yesterday it gave out
Reply With Quote Quick reply to this message
  #4  
Old 12-22-2012, 11:36 PM
Emergency Services
 

Join Date: Oct 2012
Location: South Jeerzy
Posts: 1,821
Thanks: 5
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
hope u got it all out..did u put a filter system on her?
Reply With Quote Quick reply to this message
  #5  
Old 12-23-2012, 03:20 AM
Premium Member
 

Join Date: Oct 2012
Posts: 594
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yup had coolant filter changed it every half year. Never had replaced radiator or nothing i changed all that and flushed it out. 10 time flush and started it
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:07 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors