High idle issues - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-11-2012, 04:52 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Ontario
Posts: 1,602
Thanks: 2
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
High idle issues

I've had my high idle hooked up almost two years now. I sometimes get the wrench light and code P162e unknown I clear it and it idles right up. The last few days it lonly works sometimes. I checked the conections all is good. I have noticed it doesn't seem to work when I have code p703 for the brake switch. I've got that code randomly for years just cleared it and cruise control would work again. Now I couldn't clear that code it just stayed there and high idle would not work. I wiggles a bunch of things under by the brake and high idle works. Is this coincidence or is this brake switch causing this problem. Either way where is this brake switch what does it look like and how hard is it to replace. Sorry for the long description just trying to give as much info as possible
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-11-2012, 05:09 PM
Compression Ignition Addict
 

Join Date: Jul 2012
Location: Kingwood, Texas
Posts: 247
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine does the same, didn't realize the cruise was or is part of the same problem.
Reply With Quote Quick reply to this message
  #3  
Old 11-11-2012, 05:58 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Ontario
Posts: 1,602
Thanks: 2
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
Doing some moresearch I've found there are two brake switches. One by the peddle and one under the hood by the master cylinder. Which one fixes p0703
Reply With Quote Quick reply to this message
  #4  
Old 11-11-2012, 06:03 PM
Compression Ignition Addict
 

Join Date: Jul 2012
Location: Kingwood, Texas
Posts: 247
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have read somewhere the the one by the master cylinder causes the cruise control problems. Just not sure what it looks like.
Reply With Quote Quick reply to this message
  #5  
Old 11-11-2012, 06:50 PM
Powerstroke.org Fanatic
 

Join Date: Nov 2012
Posts: 145
Thanks: 8
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Not sure if it is the same on these trucks, but allot of vehicles disable cruise control when the CEL is active as a safety precaution.
Reply With Quote Quick reply to this message
  #6  
Old 11-11-2012, 07:57 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Ontario
Posts: 1,602
Thanks: 2
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
That might be true but has nothing to do with my problem. I'm finding out this pressure switch has caused a lot of people's cruise to not work. And makes sense for my high idle not working too because when it fails the truck thinks the brakes are applied and when the brakes are applied it cancels high idle and cruise
Reply With Quote Quick reply to this message
  #7  
Old 11-13-2012, 05:44 PM
Member
 

Join Date: Oct 2006
Location: Baton Rouge
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the same issue with my cruise the one that fixed my problem is located on the bottom of the master cylinder, its the very first one from the front of the truck back as there are 2 on there. Not sure what the second one is for. after changing it never had any more problems hope this helps.
Reply With Quote Quick reply to this message
  #8  
Old 11-13-2012, 06:33 PM
Compression Ignition Addict
 

Join Date: Nov 2008
Location: Ontario
Posts: 1,602
Thanks: 2
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
G4dadon thanks for the reply I'm going to pick one up and replace it when I get home
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:43 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors