High idle issues - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 11-11-2012, 05:52 PM Thread Starter
Compression Ignition Addict
 
srjd's Avatar
 
Join Date: Nov 2008
Location: Ontario
Posts: 1,638
Thanks: 2
Thanked 9 Times in 9 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
High idle issues

I've had my high idle hooked up almost two years now. I sometimes get the wrench light and code P162e unknown I clear it and it idles right up. The last few days it lonly works sometimes. I checked the conections all is good. I have noticed it doesn't seem to work when I have code p703 for the brake switch. I've got that code randomly for years just cleared it and cruise control would work again. Now I couldn't clear that code it just stayed there and high idle would not work. I wiggles a bunch of things under by the brake and high idle works. Is this coincidence or is this brake switch causing this problem. Either way where is this brake switch what does it look like and how hard is it to replace. Sorry for the long description just trying to give as much info as possible

01/07 Job 1 F350 H&S Tuned. ARP Studs, AFE 4'' straight pipe, EGR delete with elbow, AFE stage 2 CAI, 6'' lift on 37s, 20x12 Fuel Nuts two piece, Sinister coolant filter, CCV Mod, Projector headlights HID kit
srjd is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 11-11-2012, 06:09 PM
Compression Ignition Addict
 
ATVJOE's Avatar
 
Join Date: Jul 2012
Location: Kingwood, Texas
Posts: 268
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mine does the same, didn't realize the cruise was or is part of the same problem.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2008 F250 SD King Ranch 4X4, H&S Mini DPF delete
Job 2 LB SRW Crew Cab AMP Power Running Boards
ATVJOE is offline  
post #3 of 8 Old 11-11-2012, 06:58 PM Thread Starter
Compression Ignition Addict
 
srjd's Avatar
 
Join Date: Nov 2008
Location: Ontario
Posts: 1,638
Thanks: 2
Thanked 9 Times in 9 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Doing some moresearch I've found there are two brake switches. One by the peddle and one under the hood by the master cylinder. Which one fixes p0703

01/07 Job 1 F350 H&S Tuned. ARP Studs, AFE 4'' straight pipe, EGR delete with elbow, AFE stage 2 CAI, 6'' lift on 37s, 20x12 Fuel Nuts two piece, Sinister coolant filter, CCV Mod, Projector headlights HID kit
srjd is offline  
post #4 of 8 Old 11-11-2012, 07:03 PM
Compression Ignition Addict
 
ATVJOE's Avatar
 
Join Date: Jul 2012
Location: Kingwood, Texas
Posts: 268
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have read somewhere the the one by the master cylinder causes the cruise control problems. Just not sure what it looks like.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2008 F250 SD King Ranch 4X4, H&S Mini DPF delete
Job 2 LB SRW Crew Cab AMP Power Running Boards
ATVJOE is offline  
post #5 of 8 Old 11-11-2012, 07:50 PM
Powerstroke.org Fanatic
 
Join Date: Nov 2012
Posts: 145
Thanks: 8
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Not sure if it is the same on these trucks, but allot of vehicles disable cruise control when the CEL is active as a safety precaution.
Alaskan_awd is offline  
post #6 of 8 Old 11-11-2012, 08:57 PM Thread Starter
Compression Ignition Addict
 
srjd's Avatar
 
Join Date: Nov 2008
Location: Ontario
Posts: 1,638
Thanks: 2
Thanked 9 Times in 9 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
That might be true but has nothing to do with my problem. I'm finding out this pressure switch has caused a lot of people's cruise to not work. And makes sense for my high idle not working too because when it fails the truck thinks the brakes are applied and when the brakes are applied it cancels high idle and cruise

01/07 Job 1 F350 H&S Tuned. ARP Studs, AFE 4'' straight pipe, EGR delete with elbow, AFE stage 2 CAI, 6'' lift on 37s, 20x12 Fuel Nuts two piece, Sinister coolant filter, CCV Mod, Projector headlights HID kit
srjd is offline  
post #7 of 8 Old 11-13-2012, 06:44 PM
Member
 
Join Date: Oct 2006
Location: Baton Rouge
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I had the same issue with my cruise the one that fixed my problem is located on the bottom of the master cylinder, its the very first one from the front of the truck back as there are 2 on there. Not sure what the second one is for. after changing it never had any more problems hope this helps.
g4dadon is offline  
post #8 of 8 Old 11-13-2012, 07:33 PM Thread Starter
Compression Ignition Addict
 
srjd's Avatar
 
Join Date: Nov 2008
Location: Ontario
Posts: 1,638
Thanks: 2
Thanked 9 Times in 9 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
G4dadon thanks for the reply I'm going to pick one up and replace it when I get home

01/07 Job 1 F350 H&S Tuned. ARP Studs, AFE 4'' straight pipe, EGR delete with elbow, AFE stage 2 CAI, 6'' lift on 37s, 20x12 Fuel Nuts two piece, Sinister coolant filter, CCV Mod, Projector headlights HID kit
srjd is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome