Lost power 6.4 help needed, Thanks - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 Old 07-01-2012, 11:41 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Lost power 6.4 help needed, Thanks

Return trip after 60 miles, the engine started bucking at 2000rpms, engine light came on. No power , idles fine but won't take any throttle...I was able to get home at highway speed but just barley..long time to accelerate. When I got home I disconnected the batteries to restart the PC....same. Any ideas
Also seemed like I had to lift off throttle in order for trans to shift..

Thanks,
Chuck
Steelhant is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 07-01-2012, 12:22 PM
Compression Ignition Addict
 
Join Date: Jul 2008
Location: Temple, TX
Posts: 224
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
anyway to get any codes?

2003 F350 7.3L Lariat FX4
05-07 badges
05-07 front conversion
casserly stage 2 165cc injectors
srp1.1 hpop
gtp38r (should've done h2e
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
)
custom 6 position chip
isspro ev2 gauges
6inch lift
4inch Straight Pipe
Mt's 37x13.50 R20
3.73 gears
billet converter
48 gallon fuel tank
08 Front and Rear Axles
plus more.....

soon to come: bts trans.
swalker332 is offline  
post #3 of 14 Old 07-01-2012, 01:04 PM
Powerstroke.org Fanatic
 
Join Date: Aug 2010
Posts: 146
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Could be stuck open EGR valve had an 08 with similar issue, and thats what is was if you can check codes it will tell you.
couch is offline  
post #4 of 14 Old 07-01-2012, 03:00 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
No way for me to get a code, guess i will have to go to dealer etc. Thanks for the responses.. Maybe I will look where the egr valve is and use a hammer....

Thanks Again
Steelhant is offline  
post #5 of 14 Old 07-01-2012, 04:40 PM
Powerstroke.org Fanatic
 
Join Date: Aug 2010
Posts: 146
Thanks: 1
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Don't think a hammer will do you much good the valve is run by a motor right in front of engine in the center right before intake goes into manifold on top of vertical EGR cooler as I'm typing this I can't remember what year your truck was, but there was an updated version on the later models. Dealer broke mine trying to get out with there puller I've heard of people getting them out with a crowbar, but I couldn't on my 2010. I would try an auto parts store or by a code reader or tuner they are pretty cheap now days and will tell you if thats your problem. Will say something like EGR circuit open if I remember correctly.
couch is offline  
post #6 of 14 Old 07-02-2012, 03:00 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Dropped off truck at the Ford dealer, just waiting on reply. When I find out I will post what they find. I hope they don't have to take the cab off or it will be the third time...two HP fuel pumps,,,,,,,.6.4 has been a nightmare.........

Thanks,
Chuck
Steelhant is offline  
post #7 of 14 Old 07-03-2012, 08:48 AM
Member
 
Grayson_6.4's Avatar
 
Join Date: Apr 2012
Location: Bakersfield, California
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sounds like the High Pressure Fuel Pump mine did the same exact thing when it went out.


Sent from my Autoguide iPhone app
Grayson_6.4 is offline  
post #8 of 14 Old 07-03-2012, 01:53 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Code:
Sounds like the High Pressure Fuel Pump mine did the same exact thing when it went out.
They called today....that's what happened...this is the third time, yup third.. Taking the cab off should be easy now, bolts have no time to rust...It is amazing that Ford gets away with this, a lot of 6.4 have the same issue. Still under warranty but......what happens after.....

Thanks and have a happy fourth,
Chuck
Steelhant is offline  
post #9 of 14 Old 07-03-2012, 08:33 PM
Member
 
Grayson_6.4's Avatar
 
Join Date: Apr 2012
Location: Bakersfield, California
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Damn sorry about your bad luck at least it's a warranty job. What year is your 6.4 and how many miles?


Sent from my Autoguide iPhone app
Grayson_6.4 is offline  
post #10 of 14 Old 07-04-2012, 04:45 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
08.....71,000..............
Steelhant is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome