Lost power 6.4 help needed, Thanks - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-01-2012, 10:41 AM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Lost power 6.4 help needed, Thanks

Return trip after 60 miles, the engine started bucking at 2000rpms, engine light came on. No power , idles fine but won't take any throttle...I was able to get home at highway speed but just barley..long time to accelerate. When I got home I disconnected the batteries to restart the PC....same. Any ideas
Also seemed like I had to lift off throttle in order for trans to shift..

Thanks,
Chuck
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-01-2012, 11:22 AM
Compression Ignition Addict
 

Join Date: Jul 2008
Location: Temple, TX
Posts: 221
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
anyway to get any codes?
Reply With Quote Quick reply to this message
  #3  
Old 07-01-2012, 12:04 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Posts: 105
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Could be stuck open EGR valve had an 08 with similar issue, and thats what is was if you can check codes it will tell you.
Reply With Quote Quick reply to this message
  #4  
Old 07-01-2012, 02:00 PM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No way for me to get a code, guess i will have to go to dealer etc. Thanks for the responses.. Maybe I will look where the egr valve is and use a hammer....

Thanks Again
Reply With Quote Quick reply to this message
  #5  
Old 07-01-2012, 03:40 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Posts: 105
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Don't think a hammer will do you much good the valve is run by a motor right in front of engine in the center right before intake goes into manifold on top of vertical EGR cooler as I'm typing this I can't remember what year your truck was, but there was an updated version on the later models. Dealer broke mine trying to get out with there puller I've heard of people getting them out with a crowbar, but I couldn't on my 2010. I would try an auto parts store or by a code reader or tuner they are pretty cheap now days and will tell you if thats your problem. Will say something like EGR circuit open if I remember correctly.
Reply With Quote Quick reply to this message
  #6  
Old 07-02-2012, 02:00 PM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Dropped off truck at the Ford dealer, just waiting on reply. When I find out I will post what they find. I hope they don't have to take the cab off or it will be the third time...two HP fuel pumps,,,,,,,.6.4 has been a nightmare.........

Thanks,
Chuck
Reply With Quote Quick reply to this message
  #7  
Old 07-03-2012, 07:48 AM
Member
 

Join Date: Apr 2012
Location: Bakersfield, California
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like the High Pressure Fuel Pump mine did the same exact thing when it went out.


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #8  
Old 07-03-2012, 12:53 PM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Code:
Sounds like the High Pressure Fuel Pump mine did the same exact thing when it went out.
They called today....that's what happened...this is the third time, yup third.. Taking the cab off should be easy now, bolts have no time to rust...It is amazing that Ford gets away with this, a lot of 6.4 have the same issue. Still under warranty but......what happens after.....

Thanks and have a happy fourth,
Chuck
Reply With Quote Quick reply to this message
  #9  
Old 07-03-2012, 07:33 PM
Member
 

Join Date: Apr 2012
Location: Bakersfield, California
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Damn sorry about your bad luck at least it's a warranty job. What year is your 6.4 and how many miles?


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #10  
Old 07-04-2012, 03:45 AM
Powerstroke.org Rookie
 

Join Date: Jan 2011
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
08.....71,000..............
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:16 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors