ac not cold - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-29-2012, 12:58 AM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Houston
Posts: 1,102
Thanks: 6
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
ac not cold

kinda cool but not cold. barely cooling the cab. been 100*+ in houston lately but i shouldnt be sweating my butt off in the cab. windows tinted. both sides equal temps so i dont think its the blend doors. where/how should i start the troubleshoot?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-29-2012, 04:52 AM
Powerstroke.org Rookie
 

Join Date: Mar 2012
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turn the temp down and the fan up JK Hopefully it's just a switch or fuse....pray for something simple! I just replaced the entire AC system on my 07 Freestyle....not fun! Best of luck and keep us updated.
Reply With Quote Quick reply to this message
  #3  
Old 06-29-2012, 10:27 AM
Compression Ignition Addict
 

Join Date: May 2010
Posts: 488
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Check the freon charge. The low side port is a PIA to get to. Its behind the air box, againt the firewall, under the computer wiring connections

Last edited by Antonm; 06-29-2012 at 11:09 AM. Reason: spelling
Reply With Quote Quick reply to this message
  #4  
Old 06-29-2012, 11:05 AM
Compression Ignition Addict
 

Join Date: Aug 2010
Location: central texas
Posts: 416
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I would take a look at A/c high and low side pressures and if they are low I'd recharge it and add dye and use a uv light and goggles to find what is leaking.
Reply With Quote Quick reply to this message
  #5  
Old 06-29-2012, 11:29 AM
Compression Ignition Addict
 

Join Date: Apr 2010
Location: San antonio TX
Posts: 1,274
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
I have the same issue, it blows fine just not very cold. I put a thermometer in the vent and it read anywhere from 64 to 70, and that was set on the coldest setting. I haven't checked the freon yet, that's probably where I will start.
Reply With Quote Quick reply to this message
  #6  
Old 06-29-2012, 02:23 PM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Houston
Posts: 1,102
Thanks: 6
Thanked 9 Times in 9 Posts
Feedback Score: 0 reviews
alrite ill that first.
Reply With Quote Quick reply to this message
  #7  
Old 06-29-2012, 03:42 PM
Compression Ignition Addict
 

Join Date: Apr 2011
Location: Calgary, Alberta Canada
Posts: 1,308
Thanks: 0
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
I had a similar issue in my car. Turned out to be the condesor. Had to replace it.
Reply With Quote Quick reply to this message
  #8  
Old 07-01-2012, 09:23 AM
Serving Our Country!

 

Join Date: Dec 2009
Location: NorCal
Posts: 115
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I notice during really hot days here in NorCal, the A/C gets cold but it takes a little bit...like 5-10 minutes or so. It seems to be ok after the initial cool down.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:05 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors