Wix Cap with Motorcraft Filter - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-05-2012, 05:46 AM
Member
 

Join Date: May 2012
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Wix Cap with Motorcraft Filter

Changing the Oil and Filter yesterday on my 08 F-250 6.4 and while cleaning the Oil Filter Cap I noticed written on the side of it....Wix-Do Not Reuse Cap..or something like that.
WTF.
Well I bought the truck pre owned about 6000 miles ago and had changed the oil and filter and other stuff as soon as I took ownership...I put a Motorcraft oil filter in the housing and did not even realize it had the "Wix do not reuse" cap on it. Did not even realize till this oil change yesterday...6000 miles like this. Will have to go to the Dealership today and purchase an OEM cap so I can use my Motorcraft Filter. I hope I did not hurt anything. Wondering how much unfiltered oil if any passed through the engine.
Have not noticed anything wrong lately but then again I did not notice the Wix cap on my first oil change either.
Since I'm 40 miles to the nearest dealer for a new OEM cap... I went in the wife's car down to local OReilly Auto Parts and got a Wix Filter with Cap and put it on till I get in to the dealer for new OEM cap.
Tell ya what I have noticed... But thought it was normal....Every time I started the truck after sitting a while or a cold start I would notice the "low oil pressure light would stay on for about a second. Now it does not light up at all when starting.
Like I said....Hope I did not hurt anything...Runs Great.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-07-2012, 05:01 AM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Location: Dimmitt TX
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
BUMP. Thats something that I would like to know.
Reply With Quote Quick reply to this message
  #3  
Old 06-07-2012, 05:21 AM
Member
 

Join Date: May 2012
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well.....been a few days now and I do not get a low oil pressure light coming on anymore like I had been before. Not even a blink at start up.
Since the truck was new to me I had thought the low pressure light coming on for just a second at start was the norm for this truck. Again.... I sure hope I did not do harm to the motor by running that Motorcraft Element with the Wix cap screwed down on it....Seems like I would know it by now.
Reply With Quote Quick reply to this message
  #4  
Old 06-07-2012, 05:25 AM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Location: Dimmitt TX
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just did a oil change on my truck and did the exact same thing, used a wix cap with a motorcraft filter. I am getting the same thing at start up too. I have only drove the truck 5 miles since oil change. Hopefully someone will chime in and give use the answer.
Reply With Quote Quick reply to this message
  #5  
Old 06-07-2012, 05:54 AM
Member
 

Join Date: May 2012
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by paperboy507 View Post
I just did a oil change on my truck and did the exact same thing, used a wix cap with a motorcraft filter. I am getting the same thing at start up too. I have only drove the truck 5 miles since oil change. Hopefully someone will chime in and give use the answer.
Since you know bout it I would change it out ASAP because I don't think the oil is being filtered properly. Go down and get you a Motorcraft cap and snap your Motorcraft element into the lid and slip it on.... ASAP!
Reply With Quote Quick reply to this message
  #6  
Old 06-07-2012, 05:55 AM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Location: Dimmitt TX
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Heading down to the ford house to get a new cap. Thanks for bringing it to my attention .


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:58 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors