2008 radiator coolant puking? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-27-2011, 11:07 AM
Powerstroke.org Rookie
 

Join Date: Dec 2011
Location: Yakima,wa
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2008 radiator coolant puking?

Hey guys i am new to this forum and i am looking for someone who may know a little about the 2008 radiator problems. I just installed my 3rd rad myself to save a few bucks. I have a edge programer on and tried the banks prev. and have a coolant puking problem that the dealer says they cant figure out. Can you help me out??
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-27-2011, 12:19 PM
Premium Member

 

Join Date: Jun 2011
Location: Canton, Ga
Posts: 833
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Where is it puking from?
Reply With Quote Quick reply to this message
  #3  
Old 12-27-2011, 01:21 PM
Compression Ignition Addict
 

Join Date: May 2010
Location: ORYGON
Posts: 1,266
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
R U DELETED?............MILES ON TRUCK?
Reply With Quote Quick reply to this message
  #4  
Old 12-28-2011, 06:01 AM
Powerstroke.org Rookie
 

Join Date: Dec 2011
Location: Yakima,wa
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
coolant puking

It is puking from the degas bottle, the dealer checked the cap and it holds its pressure when the have it.. The truck has 48000 and it is deleted!
Reply With Quote Quick reply to this message
  #5  
Old 12-28-2011, 06:40 AM
Compression Ignition Addict
 

Join Date: May 2010
Location: ORYGON
Posts: 1,266
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by tbern View Post
It is puking from the degas bottle, the dealer checked the cap and it holds its pressure when the have it.. The truck has 48000 and it is deleted!
do you pull anything with the truck?...what is the temp difference between coolant and oil?
Reply With Quote Quick reply to this message
  #6  
Old 12-28-2011, 12:36 PM
Powerstroke.org Rookie
 

Join Date: Dec 2011
Location: Yakima,wa
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have not been pulling anything, and i have not gotten any strange readings from temp gauges, my edge is reading trans temp and coolant temp and once they reach there reading at 192 coolant and165 for tranny they dont move but a degree or 2. It does this from normal driving , say even trips bout 20miles or so and 1 time it wont and the next time it does it really starting to get under the nerves!! Thanks for the ?'s i only wish someone had some answers??
Reply With Quote Quick reply to this message
  #7  
Old 12-28-2011, 12:37 PM
Premium Member

 

Join Date: Jun 2011
Location: Canton, Ga
Posts: 833
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You said you're deleted. Are your egr coolers deleted also?
Reply With Quote Quick reply to this message
  #8  
Old 12-28-2011, 01:01 PM
Powerstroke.org Rookie
 

Join Date: Dec 2011
Location: Yakima,wa
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No egr is not deleted but was considering doing it but don't know the pros and cons?
Reply With Quote Quick reply to this message
  #9  
Old 12-29-2011, 02:37 PM
Compression Ignition Addict
 

Join Date: Jan 2010
Posts: 296
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Injekter1 asked you oil temp and coolant temp diff. Not the trans temp. A large diff. in engine oil and coolant temp could be other problems. You are at the right place.
Reply With Quote Quick reply to this message
  #10  
Old 12-29-2011, 04:52 PM
Member
 

Join Date: Sep 2011
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the same issue...to it to the dealer, there is tsb on this issue. my dealer replaced the degas bottle, a few hoses and refilled the system...problem fixed.

Do a search and the tsb should pop up on here.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:54 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors