oil change and fuel filters.. a ticking noise afterwards? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-05-2011, 07:28 PM Thread Starter
Member
 
Join Date: Sep 2011
Location: JACKSONVILLE FLORIDA
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
oil change and fuel filters.. a ticking noise afterwards?

Well changed the oil today and it only drained about 13.5 to 14 quarts so now i know im not getting any oil growth which is good.. also changed the fuel filters and the one on the water seperator was pretty bad...now i had 2 questions there was a few metal chips on the oil plug not to many but just wondering if i should worry about it or not?? also once i changed the oil i had the hood open runnin the truck a lil. and noticed when my wife was reving it to about 2k it sounded like the turbos where ticking?? just wondering if its normal and i just never noticed before or should i worry about it ? Also managed to cut my eye open with the 36mm socket while tightening the fuel filter lol..good times
Ericr712 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-05-2011, 07:35 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Thanks: 0
Thanked 27 Times in 25 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Should be 15qts if you put in the right amount the first time?
Did you open up the oil filter while the drain plug was out?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jesilvas is offline  
post #3 of 4 Old 11-05-2011, 08:39 PM Thread Starter
Member
 
Join Date: Sep 2011
Location: JACKSONVILLE FLORIDA
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
this is my first time changing it...only had it 7k miles now..but the truck has 67k on it..but i pulled the oil filter complelty first and then pulled the plug then reinstalled both
Ericr712 is offline  
post #4 of 4 Old 11-06-2011, 04:56 PM
Member
 
RamStud's Avatar
 
Join Date: May 2010
Location: Vegas
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
if yours is the "tick" mine has right after and oil change than according to Ford its "normal". Mine does it, my brothers and my friends dont. Normal my *** but according to Ford all 10 of my issues are "normal". Its their way of not fixing problems. I have been fighting with Ford since April and nothing has been settled.

2003 XLT Excursion, 6.0, 4x4, 4" lift, 315" Toyo M/T
*SOLD*E99 XLT, crew cab long bed 4x4, 7.3, 203500 on the clock, black exterior with gray Katzkin leather interior, Beans 6 position chip, Recon billet torque converter, 6.0 trans cooler, RiffRaff 6637 intake, updated turbo with RiffRaff intake manifolds, Edge Insight, Magnaflow 5" exhaust,Firestone air bags, 10" lift, 4.88 gears, 38" Toyo M/T on chrome 20x12 Weld Dune 8's
2012 F450 Lariat 4x4, 6.7, all stock
RamStud is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome