oil change and fuel filters.. a ticking noise afterwards? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-05-2011, 06:28 PM
Member
 

Join Date: Sep 2011
Location: JACKSONVILLE FLORIDA
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oil change and fuel filters.. a ticking noise afterwards?

Well changed the oil today and it only drained about 13.5 to 14 quarts so now i know im not getting any oil growth which is good.. also changed the fuel filters and the one on the water seperator was pretty bad...now i had 2 questions there was a few metal chips on the oil plug not to many but just wondering if i should worry about it or not?? also once i changed the oil i had the hood open runnin the truck a lil. and noticed when my wife was reving it to about 2k it sounded like the turbos where ticking?? just wondering if its normal and i just never noticed before or should i worry about it ? Also managed to cut my eye open with the 36mm socket while tightening the fuel filter lol..good times
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-05-2011, 06:35 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,041
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Should be 15qts if you put in the right amount the first time?
Did you open up the oil filter while the drain plug was out?
Reply With Quote Quick reply to this message
  #3  
Old 11-05-2011, 07:39 PM
Member
 

Join Date: Sep 2011
Location: JACKSONVILLE FLORIDA
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
this is my first time changing it...only had it 7k miles now..but the truck has 67k on it..but i pulled the oil filter complelty first and then pulled the plug then reinstalled both
Reply With Quote Quick reply to this message
  #4  
Old 11-06-2011, 03:56 PM
Member
 

Join Date: May 2010
Location: Vegas
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
if yours is the "tick" mine has right after and oil change than according to Ford its "normal". Mine does it, my brothers and my friends dont. Normal my *** but according to Ford all 10 of my issues are "normal". Its their way of not fixing problems. I have been fighting with Ford since April and nothing has been settled.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:07 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors