I think my turbos are shot. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-22-2011, 04:52 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Frisco, TX
Posts: 1,147
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I think my turbos are shot.

Well today around 4pm I was at a stop light and I started to take off. Just normal acceleration, around 20 mph there was a high pitch noise and continued to make that sound up to 50-60 mph and then when I let off the gas pedal it went away. But it does it only when I press on the gas pedal. Then on the way home I floored it and it only went to 20 psi or so. Do you guys think my turbos are fubar or could it be something else?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-22-2011, 05:12 PM
Compression Ignition Addict
 

Join Date: Nov 2009
Location: Fort Collins, CO
Posts: 2,065
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Send a message via AIM to blackcloud2k Send a message via Yahoo to blackcloud2k
Check all of your boots. Sounds like you popped a boot and and now have a good sized exhaust leak. What did your EGT's looks like while it was doing this?
Reply With Quote Quick reply to this message
  #3  
Old 06-22-2011, 05:33 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Frisco, TX
Posts: 1,147
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I don't know what my egt's were.
Reply With Quote Quick reply to this message
  #4  
Old 06-23-2011, 05:13 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 4,158
Thanks: 14
Thanked 53 Times in 52 Posts
Feedback Score: 0 reviews
to me it also sounds like it could ge an intercooler boot. How many miles do you have on the truck?
Reply With Quote Quick reply to this message
  #5  
Old 06-23-2011, 01:58 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 605
Thanks: 1
Thanked 4 Times in 4 Posts
Feedback Score: 1 reviews
like the guys above said, sounds like a boost leak. Do a boost leak test first, then go from there
Reply With Quote Quick reply to this message
  #6  
Old 06-23-2011, 02:57 PM
Compression Ignition Addict
 

Join Date: May 2006
Location: Earth
Posts: 1,054
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
yup boost leak, had the same thing happen on my 01. the fun part is finding it
Reply With Quote Quick reply to this message
  #7  
Old 06-23-2011, 04:04 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2011
Posts: 131
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Since it's a 2010, it should be under warranty. Let Ford have the fun finding the leak.
Reply With Quote Quick reply to this message
  #8  
Old 06-23-2011, 04:44 PM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,218
Thanks: 21
Thanked 72 Times in 63 Posts
Feedback Score: 4 reviews
no fun involved
Reply With Quote Quick reply to this message
  #9  
Old 06-24-2011, 09:57 AM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Frisco, TX
Posts: 1,147
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Well, it turn out to be the boot from the innercooler to the cold side piping. The clamped slipped off. A little playing around with that and it fixed everything. Thanks guys for the help and the info.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:59 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors