WHY DO SO CAL FORD DEALERSHIP SERVICE DEPARTMENTS SUCK SO MUCH??? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-06-2011, 09:38 AM
Powerstroke.org Fanatic
 

Join Date: Oct 2008
Location: Reseda, California
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
WHY DO SO CAL FORD DEALERSHIP SERVICE DEPARTMENTS SUCK SO MUCH???

SO MY TRUCK HAS BEEN LAGGING LIKE CRAZY FOR THE PAST MONTH. I TOOK IT IN FOR THE DEALER TO CHECK IT OUT, AND CONVENIENTLY THEY SAID "NOTHING IS WRONG WITH YOUR TRUCK" AND ON NEW YEARS EVE I WAS LEAVING MY SHOP TO GO GET SOME LUNCH AND SHE DECIDED TO JUST TURN OFF AT ABOUT 40MPH. WONT START. SO I CALLED VISTA FORD IN WOODLAND HILLS (MY REGULAR FORD SERVICE SHOP) AND THEY SAID SORRY WE CLOSE AT 1PM AND WE CANT WAIT FOR THE TOWTRUCK TO BRING YOU IN. SO I CALLED GALPIN FORD WHO CLAIMS THEY ARE #1 IN THE NATION, AND THEY GLADLY ACCEPTED THE JOB, BUT DIDNT WANT TO GIVE ME A RENTAL. THEY CALLED ME ON TUESDAY AND SAID THE TRUCK IS DONE COME PICK IT UP. THEY SAID IT WAS THE HIGH PRESSURE FUEL LINE SEALS THAT HAD FAILED.

I PICKED HER UP AND HEADED OVER TO HOME DEPOT (1 MILE AWAY) TO LOAD UP ON SOME LUMBER FOR THE HOUSE. LOADED THE TRUCK UP AND SHE WONT START. FINALLY AFTER 20 MINUTES OF CRANKING SHE STARTS AND BUT WONT BOOST AT ALL AND IS IN LIMP MODE. WONT SHIFT OUT OF 1ST WONT DO ANYTHING. SO I LIMPED HER OVER TO THE DEALERSHIP (LITERALLY 1 MILE DOWN THE ROAD) AND THEY TOOK HER IN AGAIN.

THEY CALLED ME LAST NIGHT TO GO PICK THE TRUCK SAYING THE SAME SEAL HAD TAKEN A CRAP AGAIN. I STARTED HEADING OVER AND THEY CALLED ME AND SAID SORRY THE SAME PROBLEM IS RE-OCCURING AND IT WONT START.

NOW IM WAITING TO SEE WHAT THE HELL THEY'RE GOING TO PLAY NOW. THEY SAID THEY HAVE TO REPLACE THE HIGH PRESSURE FUEL PUMP, FUEL LINE AND ALL NEW SEALS.

ANYBODY HAVE THIS ISSUE BEFORE???????????
IM NOT TUNED, TRUCK HAS ABOUT 30K MILES, I ONLY FUEL AT CHEVRON OR MOBIL STATIONS, FUEL FILTERS WERE DONE AT 22K MILES.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-06-2011, 10:14 AM
Powerstroke.org Fanatic
 

Join Date: Oct 2008
Location: Reseda, California
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ANYONE?????
Reply With Quote Quick reply to this message
  #3  
Old 01-06-2011, 10:29 AM
Powerstroke.org Rookie
 

Join Date: Jan 2010
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Do you drain your fuel/water seperator monthly? Did the water in fuel lite come on?
Just throwin' ideas out.
I change my FF at 10k miles.

Maybe it sucked up water from that creek you went through
Reply With Quote Quick reply to this message
  #4  
Old 01-06-2011, 11:08 AM
Powerstroke.org Fanatic
 

Join Date: Oct 2008
Location: Reseda, California
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Water gets drained regularly. Water light never came on. I went through that creek months ago lolllll
they're sayign we dont have enough pressure in the high pressure side.
Reply With Quote Quick reply to this message
  #5  
Old 01-06-2011, 09:20 PM
Powerstroke.org Fanatic
 

Join Date: Oct 2008
Location: Reseda, California
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Still no answer from them.
Reply With Quote Quick reply to this message
  #6  
Old 01-06-2011, 09:29 PM
Powerstroke.org Sponsor

 

Join Date: Oct 2006
Location: Ventura County, CA
Posts: 20,361
Thanks: 23
Thanked 23 Times in 14 Posts
Feedback Score: 2 reviews
Send a message via AIM to Raul@Stealth Automotive
dude never take your truck to galpin... they balooooow... take it to sunrise ford in Fontana...
Reply With Quote Quick reply to this message
  #7  
Old 01-07-2011, 10:26 AM
Powerstroke.org Fanatic
 

Join Date: Oct 2008
Location: Reseda, California
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Raul, Mike had a world of hell at sunrise Fontana. Which brings me back to my point, WHY DO SO CAL FORD SERVICE DEPARTMENTS SUCK SO MUCH?
Reply With Quote Quick reply to this message
  #8  
Old 01-07-2011, 10:51 AM
Premium Member
 

Join Date: Nov 2007
Location: Sacarmento CA
Posts: 857
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
OK, I will take a guess. Because they don't have that much competition, and if they PO someone there are thousand more customers out there.
Reply With Quote Quick reply to this message
  #9  
Old 01-07-2011, 03:17 PM
Member
 

Join Date: Sep 2007
Location: Cedar Park
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had the HPFP go out at 117K miles...on my 08 Job 1, purchased in 2007. I don't own the truck anymore...upgraded, But the HPFP is a poor design....that's what I was told at the dealership. When the HPFP was acting up...it almost felt like the transmission was going out. The dealership where I take my truck....for service has a real good service dept....I guess....I'am lucky...good luck with your truck...and hang in there...
Reply With Quote Quick reply to this message
  #10  
Old 01-08-2011, 07:39 AM
Powerstroke.org Fanatic
 

Join Date: Oct 2008
Location: Reseda, California
Posts: 142
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I just picked up the truck late last night. What a mess this bull**** has been!
1st off the goddamn porter pulls the truck blasting some hispanic radio station with all four windows down like he owns the effing truck!
Then I get in and my alpine navi's settings and even my bluetooth has all been changed. Somebody had the nerve to connect their phone to my trucks navi while it was in there. Ca'mon how unprofessional can this get.
Then I see they "test drove" the truck about 90 miles and my truck is on E.
I was glad to have her back in running order so i said whatever I'll just deal with it i dont want anymore headaches.
WELL HEADACHES ON THIS TRUCK I GUESS ARE JUST MEANT TO BE. THE TRUCK WAS IN RE-GEN MODE WHEN I PICKED HER UP, DROVE IT 85 MILES LAST NIGHT ON THE HIGHWAY. AND SHE WONT GET OUT OF RE-GEN MODE. AND ON TOP OF IT ALL, ITS NOT BOOSTING MORE THAN 22PSI. WTF!??!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:33 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors