no power - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-19-2010, 01:52 PM Thread Starter Rookie
Join Date: Dec 2008
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no power

hey fellas, this is my first real issue with my stock 08 6.4 and lookin for info before taking to the dealer. I lost power and the engine light came on. it seems to somewhat reset itself when i shut the truck off but after a few min. it starts to loose power again. also it goes into regen. and wont come out of it. anyhow, hooked it to a buddies reader and it says common rail fuel pressure low. i thought maybe i was freezing up being in the Chicago land area but i have full power for at least 10-15 min when i start her up and also run power service regularly. i have had the egr valve replaced once already about 15,000 miles ago. i have 51,000 on her now. thanks for any input

Jetter-man is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome