MY 6.4 JUST QUIT - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 08-25-2010, 03:39 PM Thread Starter
To Many Projects
 
Twinjracing's Avatar
 
Join Date: Jun 2010
Location: Michigan City, IN
Posts: 4,108
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 28
Thanked 14 Times in 13 Posts
Feedback Score: 1 reviews
MY 6.4 JUST QUIT

As the title says my truck just quit after turring a conner and started to drive away. Ford says it's a high presure silnoid and they haft to pull the cab. any one have this problem????? is it something to worry about or just a one time thing planning a 2000 mile trip with famiy and 5th wheel next year don't want to be stuck broke down. The truck is all stock and 28000 miles on it it is an 08 thank for your in put.
Twinjracing is offline  
post #2 of 5 Old 08-26-2010, 02:39 AM
Powerstroke.org Sponsor

 
greasltn's Avatar
 
Join Date: Jan 2009
Location: Hillsborough, NC
Posts: 1,011
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If they are talking about the pressure solenoid on the HPFP, it is not a common problem unless you get water in the fuel.

-John
Rudy's Diesel Performance - 919-383-9300 - Diesel Tech

WWW.DPFDELETEKITS.COM
greasltn is offline  
post #3 of 5 Old 08-26-2010, 04:52 AM Thread Starter
To Many Projects
 
Twinjracing's Avatar
 
Join Date: Jun 2010
Location: Michigan City, IN
Posts: 4,108
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 28
Thanked 14 Times in 13 Posts
Feedback Score: 1 reviews
any thing is possable put i only buy my fuel at the same truck stop for all three of my trucks. Thanks
Twinjracing is offline  
post #4 of 5 Old 08-27-2010, 04:48 AM Thread Starter
To Many Projects
 
Twinjracing's Avatar
 
Join Date: Jun 2010
Location: Michigan City, IN
Posts: 4,108
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 28
Thanked 14 Times in 13 Posts
Feedback Score: 1 reviews
Well i talked to ford last night and they say there is a tech sheet on this problem. I should get my truck back tonight with the new and inproved part.

Twinjracing is offline  
post #5 of 5 Old 08-27-2010, 11:54 AM Thread Starter
To Many Projects
 
Twinjracing's Avatar
 
Join Date: Jun 2010
Location: Michigan City, IN
Posts: 4,108
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 28
Thanked 14 Times in 13 Posts
Feedback Score: 1 reviews
Well i got my truck back. The storry changed a nother time It was the high presser pump wiring harness that rubed throu on a bolt. Changed harness now runs good for now.
Twinjracing is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome