tick...tick...tickticktick...tick tick... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-14-2010, 07:08 PM
Member
 

Join Date: May 2010
Location: Vegas
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
tick...tick...tickticktick...tick tick...

Hello, anyone know what the tick...tick...tickticktick...tick noise is I just got on my 10 right after my first oil change? I used Motorcraft oil and filter at 5000mi. I googled it and found that some have it, some dont. From what I have read it is a mystery and does not damage anything. Any suggestions? BS like this really makes me mad, my 07 Dodge 6.7 cummins that I traded in for this truck had a similar noise; it was one of the main reasons I traded it in. Thanks for any help. (my truck is completely unaltered-stock) for now
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 07-14-2010, 10:31 PM
Warheads on Foreheads
 

Join Date: Aug 2009
Location: Houghton, LA
Posts: 1,807
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
heard it's normal also, and it always happens right after the first oil change.
Reply With Quote Quick reply to this message
  #3  
Old 07-14-2010, 11:07 PM
Compression Ignition Addict
 

Join Date: May 2008
Location: San Antonio TX ..
Posts: 2,512
Thanks: 24
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My 06 does it too ...
Reply With Quote Quick reply to this message
  #4  
Old 07-15-2010, 08:00 AM
<<< 6.4 Powersmoke
 

Join Date: Oct 2007
Location: Pocat-hell-hole, Idaho
Posts: 1,509
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My 08 has done it since I have owned it. I know the noise sounds strange, but I have the oil reports to prove it's not a problem.
Reply With Quote Quick reply to this message
  #5  
Old 07-15-2010, 08:39 AM
Banned
 

Join Date: Apr 2010
Posts: 337
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Your lucky its not "tica..tickatic..tickticktick...Youd be up Sh.. Creek if it was...
Just Joking......
Reply With Quote Quick reply to this message
  #6  
Old 07-15-2010, 10:33 AM
Powerstroke.org Rookie
 

Join Date: Apr 2010
Location: Nampa
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Had my first oil change two weeks ago (only 2,500 miles) and no ticking.
Reply With Quote Quick reply to this message
  #7  
Old 07-15-2010, 10:51 AM
<<< 6.4 Powersmoke
 

Join Date: Oct 2007
Location: Pocat-hell-hole, Idaho
Posts: 1,509
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by rpc0340 View Post
Had my first oil change two weeks ago (only 2,500 miles) and no ticking.
I haven't heard a 6.4 yet that doesn't have "the tick". My guess is that some people are more paranoid about their trucks than others, and are more aware of noises, squeaks, rattles, etc... I definitely admit that I worry excessively about my truck. However, my worry stems from leftover trauma from back when I had my 6.0
Reply With Quote Quick reply to this message
  #8  
Old 07-15-2010, 12:19 PM
Compression Ignition Addict
 

Join Date: Feb 2010
Posts: 452
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Mine does not have the tick as far as I can tell.
Reply With Quote Quick reply to this message
  #9  
Old 07-15-2010, 04:52 PM
Member
 

Join Date: May 2010
Location: Vegas
Posts: 74
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ohh ive heard it all since that oil change, "what kind of truck is that, a timex", uhh, "whats wrong with that pos", it just keeps going with my smart *** friends/co workers.
Reply With Quote Quick reply to this message
  #10  
Old 07-15-2010, 06:36 PM
Compression Ignition Addict
 

Join Date: Jan 2006
Location: Newcastle & Chico, CA
Posts: 291
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to PSDfreak
Lookup TSB 09-16-2 and it'll explain how its "normal"

Mine has it too but only when the oil is new...goes away after a thousand or so miles...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:11 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors