Random High Idle - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 06-08-2010, 06:21 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Jun 2008
Location: Northwest Mississippi
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Random High Idle

Is anyone else getting a high idle after driving the truck in and around town. No apparent reason it starts idling high around 1200 rpms. Only happens once in a while. Took it to a dealer while out of town once and he hooked it up and no codes. He told me he had heard it was to keep temps up and emissions down. Just stupid enough to be true.

Since its only happened when its been real hot I'm thinking it has something to do with keep up with the electrical and ac loading.


Any ideas?

10' F350 CC SRW LWB 6.4, Green 4x4....stock for now.
Doozer is offline  
post #2 of 3 Old 06-08-2010, 06:44 PM
KING of BLING!
 
ExtremeFord4x4's Avatar
 
Join Date: Feb 2008
Location: New Orleans(Super Bowl XLIV Champs!!)
Posts: 1,635
Thanks: 0
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My old 08 use to randomly idle high. New fuel filters fixed that problem.


2005 Ford Excursion 4x4 Limited(Current)
2006 F350 Crew Cab 6.0 Lifted 6",22's,SRL, Edge CTS(Totaled)
2003 F250 Crew Cab 6.0 Sonic Blue Sport 38s/20s(SOLD)
2001 F250 Crew Cab 7.3 w/ 08 Clip 37s/22x14s(SOLD)
2005 Excursion Limited 6.0 I.D. Tunes 38s/20s(SOLD)
2008 F350 Crew Cab 6.4 Job II 2.5" Leveling kit(SOLD)
2001 F250 Single Cab Short Bed Looney Tuned 6.0 Conversion Studded/EGR Delete(SOLD)


ExtremeFord4x4 is offline  
post #3 of 3 Old 06-09-2010, 12:00 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Jun 2008
Location: Northwest Mississippi
Posts: 144
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by ExtremeFord4x4 View Post
My old 08 use to randomly idle high. New fuel filters fixed that problem.
Now thats odd. My filters are a month old and I have a new airdog filter on it also

Oh well, as long as it does not cause problems I 'm good. I was just curious.

10' F350 CC SRW LWB 6.4, Green 4x4....stock for now.
Doozer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome