Have Problem..No Power - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-25-2010, 11:37 AM Thread Starter
Compression Ignition Addict
fairhaven's Avatar
Join Date: Feb 2010
Location: Somewhere On The West Coast
Posts: 203
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Have Problem..No Power

So we're on our way home from the store about 1 hour ago when suddenly my truck starts to chug and lose power. I thought I was going to come to a complete stop when suddenly some power came back. I was able to get home but the truck would not go over 50 and if you floored it the truck did nothing. I'll be calling the service manager first thing in the morning. I would like to have some idea, if possible, what might be going on. I filled the truck up before we went to the store (added 2oz Ford cetane booster as always) and from the station to the store she ran fine. My truck is not tuned and has about 13,500 miles on it. It is a Job 1 truck. Any ideas?

2010 F350 Lariat FX4 CC Long Box, Line X, Pueblo Gold, H&S Mini Maxx, DPF/DOC Delete, Flo Pro Down Pipe Back Stainless Exhaust, Flo Pro EGR/Cooler Delete with High Flow Intake Elbow, S&B CAI, MBRP Exhaust Tip

Last edited by fairhaven; 04-25-2010 at 12:52 PM. Reason: added info on truck
fairhaven is offline  
Sponsored Links
post #2 of 3 Old 04-25-2010, 03:16 PM
Emergency Services

Join Date: Nov 2007
Location: Hawaii
Posts: 626
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Maybe you got some bad fuel?

2008 F-350 6.4 Power Stroke 4X4
CC LWB SRW Auto 3.73's
BigIslandBoy is offline  
post #3 of 3 Old 04-27-2010, 09:55 AM
Compression Ignition Addict
Slick02's Avatar
Join Date: Oct 2008
Location: A tree in the woods of Clarcona Fl.
Posts: 466
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine is in the shop for pretty much the same thing,,and they replaced the fuel rail pressure sensor. I get it back tomorrow so we'll see if it fixed it..lol

08 F350 Lariat SWB 4x4
Spartan tunes (120 & 210)
Pro Flo DPF/cat delete 4" syst/with muffler
AFE stage II intake
2 1/2" leveling kit/Icon adj track rod
Rancho 9000 shocks
Autopage alarm/remote start
Clarion MAX675VDII/800 watt amp and 10" sub
SS black chrome side vent screens
MotoMetal 951's with Toyo 325/60R20 A/T's
Bushwacker flares/painted to match trim
Harley grille
More to come(cause I can't ever leave well enough alone)

Slick02 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome