2003 F250 A/C - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-14-2009, 09:19 PM
Powerstroke.org Rookie
 

Join Date: Feb 2009
Location: East Texas
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2003 F250 A/C

Please help. I have a '03 F250 6.0 that I'm still getting to know. The A/C is not cooling as I think it should. It starts out mildly cool and will finally blow air around 60 degrees, but it takes probably 30 minutes or so to get comfortable. Any advice or is this normal?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-20-2009, 10:26 PM
Powerstroke.org Rookie
 

Join Date: Feb 2009
Location: East Texas
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Gee,,,,, 7 days and nothing.
Reply With Quote Quick reply to this message
  #3  
Old 06-20-2009, 10:27 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2009
Location: Norco
Posts: 117
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
have you tried recharging the system?
Reply With Quote Quick reply to this message
  #4  
Old 06-21-2009, 09:02 PM
Powerstroke.org Rookie
 

Join Date: Feb 2009
Location: East Texas
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have gauges at work tonight, finally, gonna do a little government service call right after supper.
Reply With Quote Quick reply to this message
  #5  
Old 06-22-2009, 02:44 AM
Compression Ignition Addict
 

Join Date: Apr 2007
Posts: 2,564
Thanks: 10
Thanked 17 Times in 14 Posts
Feedback Score: 0 reviews
Check for vacuum leaks also
Reply With Quote Quick reply to this message
  #6  
Old 06-22-2009, 11:30 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Wasco, ca
Posts: 528
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
on the ac topic, i noticed something with my truck, when its idling at a stop the air starts to warm up, but once i start driving it cools down again. What the crap?! haha anyone might have an idea on this also? sorry for the threadjack bro.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:55 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors