lunging again - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-02-2009, 06:07 AM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Redding, Ca
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
lunging again

Ok my truck is starting to lunge again. I replaced the IPC sensor like everyone recommended, and it seemed to help for a while. Now my truck is acting up again. Its like someone just instantaneously just stabbed the accelerator pedal. Sometimes it only does it for a second and stops and other times it will hold it for 5-10 seconds. Its like something if fueling the engine. Yesterday it did it and then as the RPMs were coming down they just kept dropping and the engine died.

Any other suggestions?

Would a TPS do this and are they common?

I have no hard codes. I am going to have a buddy hook up his scanner and pull the codes.

my truck is in my sig.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-03-2009, 05:58 AM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Redding, Ca
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
bump...

any ideas
Reply With Quote Quick reply to this message
  #3  
Old 06-03-2009, 06:03 AM
wriott
Guest
 
Posts: n/a
hmmm thats a hard one. either a TPS or i dont know if i could be but would a CPS going crazy cause it??
Reply With Quote Quick reply to this message
  #4  
Old 06-03-2009, 06:10 AM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Redding, Ca
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
whats a CPS
Reply With Quote Quick reply to this message
  #5  
Old 06-03-2009, 03:26 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: KCMO
Posts: 831
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does it still act up if you take the tune off?
Reply With Quote Quick reply to this message
  #6  
Old 06-03-2009, 06:23 PM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Redding, Ca
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yes i have changed it from my xtreme tune to the canned tune, to stock and it does it with and without the tunes.
Reply With Quote Quick reply to this message
  #7  
Old 06-03-2009, 06:26 PM
wriott
Guest
 
Posts: n/a
cps is the cam position sensor
Reply With Quote Quick reply to this message
  #8  
Old 06-03-2009, 06:30 PM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Redding, Ca
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
would the cam sensor cause this problem? ive heard of it causing the engine to die or no start from the cam or crank sensor.
Reply With Quote Quick reply to this message
  #9  
Old 06-18-2009, 06:06 PM
Compression Ignition Addict
 

Join Date: Sep 2008
Location: Redding, Ca
Posts: 229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I still have this problem and no one can figure out what is causing this. I took it to the shop and had the comp scanned and the only thing he found is a P0603 (soft code) Internal control module KAM error. I did a little searching on here and it looks like my programmer caused this.

I’m just frustrated and cannot figure this out. i wish it would through a CEL to give me some direction.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:29 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors