EGR DELETE DONE AND NOW IT RUNS ROUGH WITH NO BOOST. - Ford Powerstroke Diesel Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 05-16-2009, 09:19 AM Thread Starter
Compression Ignition Addict
 
Gforce33's Avatar
 
Join Date: Apr 2009
Location: Edmonton, Alberta
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
EGR DELETE DONE AND NOW IT RUNS ROUGH WITH NO BOOST.

Hi guys, so.....I attempted to do an egr delete on my truck with not a lot of mechanical knowledge and now I have a bigger problem on my hands. I did the egr delete and I also replaced the oil cooler. When I went to restart my truck after everything was put back together, the truck engine smoked like crazy, ran very rough, my turbo is making a strange noise and I get zero boost. When I initially started the delete mod, the turbo was working fine. Could I have screwed up on the oil cooler and no oil is going to my turbo? Would not putting the gaskets back on the intake properly cause this problem?? Where did I go wrong and could anybody give me some advice as to where to start looking? Thanks!!

2005 F350 Kingranch FX4 Dually
6.0L Diesel,
Elite/Liberator EGR Delete.
K&N Stage II Intake.
4" MBRP Turbo Back Exhaust, Kitty Gone
2003 International Turbo.
SCT X3 SRL Tune by Matt @ Gearhead and ID's tow and street via Adam.
3 Gauge pillar W/pyro, trans and Boost

Last edited by Gforce33; 05-16-2009 at 09:58 AM.
Gforce33 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 05-16-2009, 12:07 PM
Compression Ignition Addict
 
CCSBD's Avatar
 
Join Date: Oct 2008
Location: Indpls., IN.
Posts: 1,274
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sucks to hear man, heres a for ya

***SOLD***
'04 CrewCab ShortBed 6.0 4x4
Black FX4 Sport
6K HID's
CCV Mod
03 Turbo
6.4 Banjo's
Zoodad Mod
4.5" Icon Lift
High Idle Mod
ARP Headstuds
RCD EGR Delete
Updated FPR Spring
Sinister Coolant Filter
Recon Smoked Cab Lights
SCT X3 Tuned by Innovative
4" MBRP SS Turbo Back Exhaust
ISSPRO EV pyro, trans, boost guages
CCSBD is offline  
post #3 of 11 Old 05-16-2009, 10:39 PM
Compression Ignition Addict
 
ciscofreak's Avatar
 
Join Date: Apr 2007
Location: Sivlerdale, WA
Posts: 226
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
I just finished deleting the EGR system on my truck too and it too ran rough and smoked for the first 10 minutes or so. It then leveled out.

As for boost, you may want to do the VGT relearn procedure. I cant remeber exactly how it goes but someone on here can give you the steps...

13 F350 Lariat CC LWB


ciscofreak is online now  
post #4 of 11 Old 05-17-2009, 06:54 AM
Powerstroke.org Fanatic
 
zspear1's Avatar
 
Join Date: May 2007
Posts: 121
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would check the obvious first such as sensor connections and wiring harness and verify the VGT circuit connection an operation. Is the CEL on? Make sure IAT sensor is plugged in because they will run real rough when it's not and make the same symptoms your describing. If it was running good before you started then your problem is bound to be related to your remove and install of all your components. Only thing to do is back track your work from start to finish till you find the flaw. Also if you disconnected the wiring harness from the ECM check the wires behind the bus connection some of these harnesses rub on the valve cover edge and can short out. Other than that make sure all grounds are connected and I know this sounds dumb but make sure you did not leave a rag stuffed in intake line or something along those lines. The way you describe the symptoms it sounds like you might have left somthing un-plugged.

2006 crew cab XLT, Fx4 6.0 stroke, torqe shift trans, deleted EGR, Turn over ball GN.
zspear1 is offline  
post #5 of 11 Old 05-17-2009, 06:59 AM
Compression Ignition Addict
 
Join Date: Jul 2008
Posts: 419
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you change your oil after doing the egr delete?
rock hardson is offline  
post #6 of 11 Old 05-17-2009, 08:39 AM
Compression Ignition Addict
 
03f250stroke's Avatar
 
Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
yeah i would check all the connections, make sure you didnt pull any wires from any clips. make sure you put the ground wire back on the intake manifold back by the turbo there.

you cant really mess up the gasket because it has align holes for the bolts. no boost to the turbo is odd. probably electrical. no oil to turbo and that thing would be smoking and screaming

-Evan

6.HO
tuned by Eric
12.3

Quote:
Originally Posted by shu873 View Post
Yeah, but your trucks a freak of nature...
03f250stroke is offline  
post #7 of 11 Old 05-17-2009, 11:14 AM
Compression Ignition Addict
 
Join Date: Jul 2008
Posts: 419
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What kit did you go with or did you make it yourself? Just out of curiosity.
rock hardson is offline  
post #8 of 11 Old 05-18-2009, 07:35 AM Thread Starter
Compression Ignition Addict
 
Gforce33's Avatar
 
Join Date: Apr 2009
Location: Edmonton, Alberta
Posts: 200
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for all your help guys, I am baffled. I did the elite egr delete and it is actually pretty good! As for the truck, I got it towed to a mechanic.....hopefully he can figure it out as I went through it and the ground was plugged back in, all the other plugs were back in, and visually everything looked OK. My alternator seems to be crapping out as well, the ground plugged into it got very hot and was smoking last time I started it.....now the alt light is coming on.

2005 F350 Kingranch FX4 Dually
6.0L Diesel,
Elite/Liberator EGR Delete.
K&N Stage II Intake.
4" MBRP Turbo Back Exhaust, Kitty Gone
2003 International Turbo.
SCT X3 SRL Tune by Matt @ Gearhead and ID's tow and street via Adam.
3 Gauge pillar W/pyro, trans and Boost
Gforce33 is offline  
post #9 of 11 Old 06-13-2009, 08:16 AM
Serving Our Country!
 
bulldog84's Avatar
 
Join Date: Jul 2008
Location: SE, Missouri
Posts: 586
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'm interested in what was wrong. I'm getting ready to do the same thing to my truck.

2004 F-250 FX4 6.0L
Full EGR Delete (First Coast Diesel Performance)
SCT SF3 (Innovative Diesel Custom Tuning)
Black Onyx Head Gaskets (River City Diesel)
Coolant Filtration System (Dieselsite)
4" MBRP Turbo Back Straight Pipe
K&N FIPK w/S&B Filter
BFG A/T's 285/75/16
ARP Head Studs
2" Leveling Kit
Edge Insight
Zoodad Mod
Recon Lights
New FICM
03 Turbo
OIF Army Veteran
bulldog84 is offline  
post #10 of 11 Old 06-13-2009, 08:24 AM
Compression Ignition Addict
 
Huckleberry's Avatar
 
Join Date: May 2009
Location: Tenino, Wa
Posts: 230
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sound like you got some wire crossed up somewhere a ground wire should never get hot and smoke, you've got power going somewhere it shouldn't therefore something else isn't getting power.

2004 F250
  • Zoo Dad Mod
  • High Idle Mod
  • Lost Cat Mod
Huckleberry is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome