is it my turbo? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-25-2007, 01:36 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
is it my turbo?

hey, another newbe here.

I have 03 with stock pipe cat & muf delete, and edge juice(no attitude).
the other day i was showing my 12 year old the proper way to lite em up (the tires), about the time that things were geting loud I had to get out of it real fast (due to red and blue lights)! It made a funny noise, and since then does not seem to have the same throw your head back take off. I can still hear the turbo through the tail pipe.It still runs good just seems to be missing something. is it probably my turbo?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-25-2007, 01:40 PM
Compression Ignition Addict
 

Join Date: Aug 2006
Posts: 280
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i would think maybe a boost tube came apart but you wouldnt have any power. you still have power so......
maybe someone else can help.
Reply With Quote Quick reply to this message
  #3  
Old 01-25-2007, 01:54 PM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i checked the boost tube, all seem good.
Reply With Quote Quick reply to this message
  #4  
Old 01-26-2007, 08:35 AM
Powerstroke.org Rookie
 

Join Date: Jan 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i read a post about the vanes sticking. what would i notice if this has happened?
Reply With Quote Quick reply to this message
  #5  
Old 01-27-2007, 07:31 AM
Banned
 

Join Date: Jan 2006
Location: central coast, california
Posts: 0
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Is it a fluttering noise like chugchugchugchug really fast....back through the intake when you let off after a hard accell?? If it is it is completely normal and i can make every 6.0 out there do it. Its excess turbo boost basically being vented back through the intake since it has nowere else to go....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:38 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors