can't get speedo to read right - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-31-2009, 06:00 PM Thread Starter
Member
 
Join Date: Feb 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
can't get speedo to read right

I got a 04 f250 6.0, bought it with a lift and 355/60/20 and other than that thats really all i know, got the sct tuner and have been trying to set the tire revs and the axle ratio, but no matter what the speedo is always off, the best i had it was 5 mph off, but the truck was shifting all kinds of funny, and just seemed gutless....like it was stock again on the extreme tune, 4.10 axle ratio and 560 rpm on tire setting, the axle tags are missing so im not sure what to set and what to set it to? anyone have any ideas or solution, im going off my navigon gps, holds true in my other car so i don't think its off, also if i get the tire/axle ratio setting correct i'll be able to see how many real mpg im getting right? cuz if the speedo is off than the odometer is off as well so i can't do the math =) the lie o meter up top says 12-12.5 and i know i should be getting more than that..any help would be appreciated. sory for the long winded story
tootall is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-31-2009, 06:13 PM
Compression Ignition Addict
 
Join Date: Sep 2007
Posts: 170
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
You need to know what gears are in it for sure. You can try and different ratio and the rest to see if it gets closer. 3.73, 4.10, 4.56

2002 F-350 Crew Cab 4X4 Donahoe Lift kit, 38" Toyo open country mudd, AMP research Steps, 4.56 Gears, Mag Hytec Diffcover and Tranny Pan, Superchip, AFE Stage 2,Wicked Wheel, 4" exhaust turbo back.
dirtbikeguy2003 is offline  
post #3 of 3 Old 03-31-2009, 06:16 PM Thread Starter
Member
 
Join Date: Feb 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i don't know how to tell what gears it has, axle tags are missing so i can't get the code from it, just lil annoying...its been on 3.73 as i thought it was stock and the previous owner just replaced the diff covers, but its 8-10 mph off at freeway speeds, going 55 tach reads 1550-1600rpm with 3.73 setting and 560 on tire rpm
tootall is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome